[Bug 79578] Re: Regression: grub - Error 18 when using savedefault (feisty/edgy)

Phillip Susi psusi at ubuntu.com
Fri Sep 14 17:04:56 UTC 2012

** No longer affects: grub2 (Ubuntu)

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to grub in Ubuntu.

  Regression: grub - Error 18 when using savedefault (feisty/edgy)

Status in “grub” package in Ubuntu:
  Fix Released

Bug description:
  Binary package hint: grub


  I installed edgy on a logical partition (hda7) on an old PIII with one single 80 GB Harddisk
  a few days ago.
  On the same partition I had some other Ubuntu or Debian before Dapper without any problems.
  (I use two alternately to install)

  Today I got grub Error 18 the 2nd time. (most time it works, but
  sometimes not !)

  First time:
   I had grub from edgy in hda7 and one from dapper in MBR (chainloading hda7)
   (like I decided to install for trying - Installation was normal) 
  Suddenly I could not boot edgy any more. 
  (Didn'd change anything but maybe an update occoured)
  Solved it this time:
  After reboot I edited one entry in my first grub loarded from MBR (installed from Dapper) to load
  edgy from hda7 - surprise it booted !

  After that I installed grub from edgy in MBR. (no chainloading any

  That worked again for some days.
  (I booted the machine between three and five times a day or maybe more using suspend to disk)

  Second time: (today)
  Suddenly I could not boot edgy any more. (again)
  Solved it this time:
  Booted from floppy (grub installed there from Breezy)
  Typed on grub console exactly what is in menu.lst (root, kernel with all params, initrd)
  but without savedefault, quiet and then "boot" - surprise it booted again !

  Then I googled and found this:

  Package: grub
  Version: 0.97-5
  Severity: important

  *** Please type your bug below this line ***
  I have a Fujitsu Scaleo 600. Sometimes the system doesn't start after
  the last upgrade one week ago. The message when start the computer is:
  "Grub is initializing ....", and after 30 seconds the message is:
  "Error 18". Although if Irestart five or more times the system start,
  and the grub works well. Is there a bug on this version of grub for my
  type of computer?

  And on packages.ubuntu.com:
  # dapper (admin): GRand Unified Bootloader
  0.97-1ubuntu9: amd64 i386
  # edgy (admin): GRand Unified Bootloader
  0.97-11ubuntu14: amd64 i386 

  So I am realy afraid, there was a bug introduced into grub on edgy.

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list