[Bug 1048091] Re: dh_python3: TypeError when maximum version is specified

Bug Watch Updater 1048091 at bugs.launchpad.net
Mon Sep 10 21:18:50 UTC 2012

** Changed in: python3-defaults (Debian)
       Status: Unknown => New

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to python3-defaults in Ubuntu.

  dh_python3: TypeError when maximum version is specified

Status in “python3-defaults” package in Ubuntu:
Status in “python3-defaults” package in Debian:

Bug description:
  Package: python3-defaults
  Version: 3.2.3-5

  I was building a deb package using python3 in my PPA.  I want to
  specify a range of python3 version, but dh_python3 causes an error as
  follows if the maximum version is specified:

  Traceback (most recent call last):
    File "/usr/bin/dh_python3", line 490, in <module>
    File "/usr/bin/dh_python3", line 422, in main
      dependencies.parse(stats, options)
    File "/usr/share/python3/debpython/depends.py", line 158, in parse
      self.depend("python3 (<< %s)" % vrepr(vr[1] + 1))
  TypeError: can only concatenate tuple (not "int") to tuple

  I specified the python3 version in debian/control as follows:

    X-Python3-Version: >= 3.2, << 3.3

  The same error happens when I use -V command line option like:

    dh_python3 -V 3.2-3.3

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list