[Bug 1048733] Re: add-apt-repository fails due to softwareproperties error

Walter Lapchynski 1048733 at bugs.launchpad.net
Mon Sep 10 17:29:37 UTC 2012

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to software-properties in Ubuntu.

  add-apt-repository fails due to softwareproperties error

Status in “software-properties” package in Ubuntu:

Bug description:
  $ sudo add-apt-repository ppa:lubuntu-dev/lubuntu-daily
  Traceback (most recent call last):
    File "/usr/bin/add-apt-repository", line 10, in <module>
      from softwareproperties.SoftwareProperties import SoftwareProperties
  ImportError: No module named softwareproperties.SoftwareProperties

  I tried other PPAs and had the same error so it seems to be universal.

  Interestingly trying to add manually in Settings → Repository just
  results in a notice saying that repos have changed and you need to
  reload. It doesn't actually get to the point where you add repos. That
  may be a related issue so I will file a separate bug and link here and
  vice versa.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: python-software-properties 0.92.1
  ProcVersionSignature: Ubuntu 3.4.0-5.11-generic 3.4.0
  Uname: Linux 3.4.0-5-generic i686
  ApportVersion: 2.1.1-0ubuntu2
  Architecture: i386
  Date: Mon Sep 10 10:15:50 2012
  InstallationMedia: Lubuntu 12.04 "Precise Pangolin" - Alpha i386 (20120215)
  PackageArchitecture: all
   PATH=(custom, user)
  SourcePackage: software-properties
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list