[Bug 309945] Re: [jaunty, intrepid] Hard system freeze using open-iscsi

BlueLight 309945 at bugs.launchpad.net
Mon Sep 10 03:58:36 UTC 2012

** Changed in: open-iscsi (Ubuntu)
       Status: New => Incomplete

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to open-iscsi in Ubuntu.

  [jaunty, intrepid] Hard system freeze using open-iscsi

Status in “open-iscsi” package in Ubuntu:

Bug description:
  Binary package hint: open-iscsi


  I installed iscsitarget on my host, and in a kvm guest, I tried to use
  my configured target. First my setup:

  Intrepid, latest proposed linux image (with fixes for iscsitarget)

  cat /etc/ietd.conf | grep -ve ^.*# -ve ^$
  Target iqn.2008-12.de.roessner-net:storage.disk0.testing
  	Lun 0 Path=/dev/vg01/lv_testing,Type=fileio
  	Alias Test
  	HeaderDigest		CRC32C,None
  	DataDigest		CRC32C,None

  The host is still running fine, with following dmesg-output, after the
  guest has been died:

  [ 2220.173286] vcpu not ready for apic_round_robin
  [ 2220.670873] vcpu not ready for apic_round_robin
  [ 2220.673095] vcpu not ready for apic_round_robin
  [ 2221.171379] vcpu not ready for apic_round_robin
  [ 2221.173452] vcpu not ready for apic_round_robin
  [ 2278.588125] vcpu not ready for apic_round_robin

  Does not wonder me, because the guest is dead :-)

  The guest:

  Jaunty (Former Intrepid with same results):

  Here the commands, I set in the guest, directly copied over from the
  dead console:

  ubuntu /etc/rcS.d # mv S25open-iscsi S45open-iscsi
  ubuntu /etc/rcS.d # vi S45open-iscsi 
  ubuntu /etc/rcS.d # cd
  ubuntu ~ # cd /etc/iscsi/
  ubuntu /etc/iscsi # vi iscsid.conf 
  ubuntu /etc/iscsi # iscsiadm -m discovery -tst -p -d3
  iscsiadm: Max file limits 1024 1024

  iscsiadm: starting sendtargets discovery, address, 
  iscsiadm: connecting to
  iscsiadm: connected local port 53014 to
  iscsiadm: connected to discovery address
  iscsiadm: login response status 0000
  iscsiadm: discovery process to exiting
  iscsiadm: Could not open /etc/iscsi/send_targets/,3260 err 2,1 iqn.2008-12.de.roessner-net:storage.disk0.testing
  ubuntu /etc/iscsi # iscsiadm -m node -T iqn.2008-12.de.roessner-net:storage.disk0.testing -p -l
  Logging in to [iface: default, target: iqn.2008-12.de.roessner-net:storage.disk0.testing, portal:,3260]
  Login to [iface: default, target: iqn.2008-12.de.roessner-net:storage.disk0.testing, portal:,3260]: successful
  ubuntu /etc/iscsi # 


  I only changed two things in the config file. I set manual to
  automatic mount and enabled CRC32 stuff for header and data.

  I first had tested this setup on my development server with 4 guests
  using one target with ocfs2. On the intrepid nodes, I could mount the
  partition and start bonnie++. But after a while, all nodes died. So
  this time I tried to set up a little testing scenario here at my home
  desktop, to fill this bug and as you can see, it also crashes.

  If you can speak german, you may find more detailed information here
  in my blog:


  iSCSI would be a good solution for not using NFS.

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list