[Bug 1048078] [NEW] daily emails to root with unnecessary warning messages

jimav 1048078 at bugs.launchpad.net
Sun Sep 9 01:26:27 UTC 2012


Public bug reported:

/etc/cron.daily/popularity-contest generates many messages to be emailed
to root every day.

It looks like it is trying to get information about packages whether or
not they are installed?  If so it should suppress the error/warning
messages for missing packages (assuming they are really not anything
which needs human attention).

Alternatively, if there really are missing packages which should be
there, then there must be some missing dependencies somewhere.

--------------- mail from Anacron jog 'cron.daily'
-------------------------

/etc/cron.daily/popularity-contest:
Package `gtk2-engines-oxygen' is not installed.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
Package `ia32-libs-multiarch' is not installed.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
Package `libgail-common' is not installed.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
Package `libmikmod2' is not installed.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
Package `libqt4-scripttools' is not installed.
Package `libqt4-test' is not installed.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
Package `libsdl-image1.2' is not installed.
Package `libsdl-mixer1.2' is not installed.
Package `libsdl-net1.2' is not installed.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
Package `libssl0.9.8' is not installed.
Package `libstdc++5' is not installed.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
Package `nspluginviewer' is not installed.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
Package `skype' is not installed.
Package `skype-bin' is not installed.
Package `sni-qt' is not installed.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
Package `wine1.4-i386' is not installed.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: popularity-contest 1.53ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
Date: Sat Sep  8 18:20:36 2012
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: popularity-contest
UpgradeStatus: Upgraded to precise on 2012-08-10 (29 days ago)

** Affects: popularity-contest (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: amd64 apport-bug precise

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to popularity-contest in Ubuntu.
https://bugs.launchpad.net/bugs/1048078

Title:
  daily emails to root with unnecessary warning messages

Status in “popularity-contest” package in Ubuntu:
  New

Bug description:
  /etc/cron.daily/popularity-contest generates many messages to be
  emailed to root every day.

  It looks like it is trying to get information about packages whether
  or not they are installed?  If so it should suppress the error/warning
  messages for missing packages (assuming they are really not anything
  which needs human attention).

  Alternatively, if there really are missing packages which should be
  there, then there must be some missing dependencies somewhere.

  --------------- mail from Anacron jog 'cron.daily'
  -------------------------

  /etc/cron.daily/popularity-contest:
  Package `gtk2-engines-oxygen' is not installed.
  Use dpkg --info (= dpkg-deb --info) to examine archive files,
  and dpkg --contents (= dpkg-deb --contents) to list their contents.
  Package `ia32-libs-multiarch' is not installed.
  Use dpkg --info (= dpkg-deb --info) to examine archive files,
  and dpkg --contents (= dpkg-deb --contents) to list their contents.
  Package `libgail-common' is not installed.
  Use dpkg --info (= dpkg-deb --info) to examine archive files,
  and dpkg --contents (= dpkg-deb --contents) to list their contents.
  Package `libmikmod2' is not installed.
  Use dpkg --info (= dpkg-deb --info) to examine archive files,
  and dpkg --contents (= dpkg-deb --contents) to list their contents.
  Package `libqt4-scripttools' is not installed.
  Package `libqt4-test' is not installed.
  Use dpkg --info (= dpkg-deb --info) to examine archive files,
  and dpkg --contents (= dpkg-deb --contents) to list their contents.
  Package `libsdl-image1.2' is not installed.
  Package `libsdl-mixer1.2' is not installed.
  Package `libsdl-net1.2' is not installed.
  Use dpkg --info (= dpkg-deb --info) to examine archive files,
  and dpkg --contents (= dpkg-deb --contents) to list their contents.
  Package `libssl0.9.8' is not installed.
  Package `libstdc++5' is not installed.
  Use dpkg --info (= dpkg-deb --info) to examine archive files,
  and dpkg --contents (= dpkg-deb --contents) to list their contents.
  Package `nspluginviewer' is not installed.
  Use dpkg --info (= dpkg-deb --info) to examine archive files,
  and dpkg --contents (= dpkg-deb --contents) to list their contents.
  Package `skype' is not installed.
  Package `skype-bin' is not installed.
  Package `sni-qt' is not installed.
  Use dpkg --info (= dpkg-deb --info) to examine archive files,
  and dpkg --contents (= dpkg-deb --contents) to list their contents.
  Package `wine1.4-i386' is not installed.
  Use dpkg --info (= dpkg-deb --info) to examine archive files,
  and dpkg --contents (= dpkg-deb --contents) to list their contents.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.04
  Package: popularity-contest 1.53ubuntu1
  ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
  Uname: Linux 3.2.0-29-generic x86_64
  NonfreeKernelModules: fglrx
  ApportVersion: 2.0.1-0ubuntu12
  Architecture: amd64
  Date: Sat Sep  8 18:20:36 2012
  InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
  PackageArchitecture: all
  ProcEnviron:
   LANGUAGE=
   TERM=xterm
   PATH=(custom, user)
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: popularity-contest
  UpgradeStatus: Upgraded to precise on 2012-08-10 (29 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/popularity-contest/+bug/1048078/+subscriptions




More information about the foundations-bugs mailing list