[Bug 1034568] Re: build-essential shouldn't be Multi-Arch: foreign

Launchpad Bug Tracker 1034568 at bugs.launchpad.net
Sat Sep 8 11:09:14 UTC 2012


This bug was fixed in the package build-essential - 11.5ubuntu2.1

---------------
build-essential (11.5ubuntu2.1) precise; urgency=low

  * Revert the previous change, we shouldn't be foreign (LP: #1034568)
 -- Adam Conrad <adconrad at ubuntu.com>   Sun, 08 Jul 2012 15:43:24 -0600

** Changed in: build-essential (Ubuntu Precise)
       Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to build-essential in Ubuntu.
https://bugs.launchpad.net/bugs/1034568

Title:
  build-essential shouldn't be Multi-Arch: foreign

Status in “build-essential” package in Ubuntu:
  Fix Released
Status in “build-essential” source package in Precise:
  Fix Released

Bug description:
  During precise development, build-essential was incorrectly marked
  Multi-Arch: foreign.  This directly contradicts the multi-arch cross-
  building spec, and broke when dpkg started properly implementing that
  spec in quantal.

  This bug has already been fixed in quantal, but the fix should be
  backported to precise for correctness (in case someone uses the
  quantal dpkg with the precise build-essential, or some other
  interesting combination).

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/build-essential/+bug/1034568/+subscriptions




More information about the foundations-bugs mailing list