[Bug 1047384] Re: System Encryption Password set before setting keyboard locale

Dmitrijs Ledkovs launchpad at surgut.co.uk
Fri Sep 7 15:24:53 UTC 2012

<slangasek> I like solution #1
<stgraber> xnox: going with a random key, then adding the real one and removing the random one sounds like a good idea

@mpt: at this point are you going to start saying that we should reuse
login password as the full disk encryption password?

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to ubiquity in Ubuntu.

  System Encryption Password set before setting keyboard locale

Status in “ubiquity” package in Ubuntu:

Bug description:
  When installing my system, I selected to encrypt access to my system.

  This prompted me to enter a password.

  I entered a password with a # symbol in it, however due to using an
  english keyboard, this would not have been correctly recorded as a #,
  but as a ' instead - leading it to refuse my password when booting.

  I tested this both connected to and not connected to the internet.

  It seems that at the point of entering the password during the
  installer, the keyboard layout was set to en_US.

  Therefore, when booting and having the locale as en_GB - it didn't
  correctly work.

  I tried this with the @ symbol, which when entered was accepted on
  boot by hitting shift+2 (american combination)

  I also tried this by entering a password with a £ sign (shift 3 on UK
  keyboard - which would be a # on a US keyboard)

  When entering password on boot, entering the password with the # key
  rather than the £ key worked.

  In summary - when entering password for encrypting system, keyboard is
  set as a US keyboard layout, which differs from that when booting to
  enter the password if it is changed in a later step.

  Proposed solution: Move the keyboard selection / Locale Setup before
  any input boxes. (espescially those where you can't see the contents
  of them!)

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: ubiquity (not installed)
  ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
  Uname: Linux 3.5.0-13-generic x86_64
  NonfreeKernelModules: wl
  ApportVersion: 2.5.1-0ubuntu4
  Architecture: amd64
  Date: Fri Sep  7 14:40:18 2012
  InstallCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
  InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120905.2)
   PATH=(custom, no user)
  SourcePackage: ubiquity
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list