[Bug 1046319] Re: glib 2.33.12 crashes libgdata

Martin Pitt martin.pitt at ubuntu.com
Thu Sep 6 04:36:31 UTC 2012


glib fix uploaded to Debian experimental, will sync to quantal-proposed
once it's imported.

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to glib2.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1046319

Title:
  glib 2.33.12 crashes libgdata

Status in “glib-networking” package in Ubuntu:
  Fix Committed
Status in “glib2.0” package in Ubuntu:
  Fix Committed

Bug description:
  With the new glib version, libgdata crashes when used from python.

  It consequently triggers crashes, notably in unity-scope-gdocs and
  unity-lens-photos.

  Shotwell export to Picasa and Gnome-Documents Google Docs search are
  not working either, but the relation with this bug needs to be
  confirmed.

  Testcase:
  $ sudo apt-get install gir1.2-gdata-0.0
  $ python3
  from gi.repository import GData
  s = GData.Service ()

  
  Output:
  __main__:1: Warning: g_object_class_override_property: Can't find property to override for 'GTlsCertificateGnutls::certificate-bytes'
  __main__:1: Warning: g_object_class_override_property: Can't find property to override for 'GTlsCertificateGnutls::private-key-bytes'
  __main__:1: Warning: g_object_get_valist: object class `GTlsCertificateGnutls' has no property named `certificate-bytes'

  (process:8781): GLib-Net-CRITICAL **: get_der_for_certificate:
  assertion `bytes' failed

  (process:8781): GLib-Net-CRITICAL **: load_anchor_file: assertion `der != NULL' failed
  **
  GLib-Net:ERROR:gtlsbackend-gnutls.c:149:g_tls_backend_gnutls_get_default_database: assertion failed: (result)
  Abandon (core dumped)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/glib-networking/+bug/1046319/+subscriptions




More information about the foundations-bugs mailing list