[Bug 1046181] Re: Upgrade from Lucid to Precise failed due to 'python-minimal'

Kedar Joshi kedarpjoshi at gmail.com
Wed Sep 5 07:46:26 UTC 2012


Added /var/log/dist-upgrade/main.log file as a separate attachment

** Attachment added: "Adding main.log"
   https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1046181/+attachment/3293480/+files/main.log

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to update-manager in Ubuntu.
https://bugs.launchpad.net/bugs/1046181

Title:
  Upgrade from Lucid to Precise failed due to 'python-minimal'

Status in “update-manager” package in Ubuntu:
  New

Bug description:
  Hi,

  I have Ubuntu 10.04 LTS - Lucid Lynx. I was long time waiting for 23rd Aug 2012 for directly upgrading to Ubuntu 12.04.01 LTS. As my internet link is very slow, i spent several hours [almost 1.5 days] and downloaded all the packages [859 MB of download] using the update-manager tool. I was very disaapointed to see the same problem that is being discussed here -
  SystemError: E:Could not perform immediate configuration on 'python-minimal'

  I dont want spend any more time downloading all the packages again and
  try to upgrade again. Can some one please tell me how to fix the
  problem with minimal effort?

  also when i tried solution mentioned in -
  https://bugs.launchpad.net/ubuntu/+source/python-defaults/+bug/990740?comments=all

  Following happens-

  kirti at kirtis-desktop:~$ sudo apt-get install -o APT::Immediate-Configure=false --reinstall python-minimal
  Reading package lists... Done
  Building dependency tree
  Reading state information... Done
  Some packages could not be installed. This may mean that you have
  requested an impossible situation or if you are using the unstable
  distribution that some required packages have not yet been created
  or been moved out of Incoming.
  The following information may help to resolve the situation:

  The following packages have unmet dependencies:
    gnome-icon-theme: Breaks: gnome-games (< 1:2.30.2-1) but 1:2.30.0-0ubuntu6 is to be installed
    libasound2: Breaks: libasound2-plugins (< 1.0.24) but 1.0.22-0ubuntu6 is to be installed
    libglib2.0-0: Breaks: gnome-control-center (< 1:3) but 1:2.30.1-0ubuntu2 is to be installed
                  Breaks: gvfs (< 1.8) but 1.6.1-0ubuntu1build1 is to be installed
    libpango1.0-0: Breaks: plymouth (< 0.8.2-2ubuntu19) but 0.8.2-2ubuntu2.2 is to be installed
    ppp: Breaks: network-manager (<= 0.8.0.999-1) but 0.8-0ubuntu3.3 is to be installed
         Breaks: network-manager-pptp (<= 0.8.0.999-1) but 0.8-0ubuntu3 is to be installed
  E: Broken packages

  Also tried -
  sudo apt-get -f install
  [sudo] password for kirti:
  Reading package lists... Done
  Building dependency tree
  Reading state information... Done
  The following packages were automatically installed and are no longer required:
    sdparm
  Use 'apt-get autoremove' to remove them.
  0 upgraded, 0 newly installed, 0 to remove and 1200 not upgraded.

  Then i tried with what you suggested -

  apport-cli -p update-manager -u 990740
  The authorization page:
     (https://edge.launchpad.net/+authorize-token?oauth_token=BvrMPVB88xtCXNrmHBbf&allow_permission=WRITE_PRIVATE)
  should be opening in your browser. After you have authorized
  this program to access Launchpad on your behalf you should come
  back here and press <Enter> to finish the authentication process.

  *** Error: Updating problem report

  You are not the reporter or subscriber of this problem report, or the
  report is a duplicate or already closed.

  Please create a new report using "apport-bug".

  Press any key to continue...

  No pending crash reports. Try --help for more information.

  ProblemType: Bug
  DistroRelease: Ubuntu 10.04
  Package: update-manager 1:0.134.12.1
  ProcVersionSignature: Ubuntu 2.6.32-41.94-generic 2.6.32.59+drm33.24
  Uname: Linux 2.6.32-41-generic i686
  Architecture: i386
  Date: Wed Sep  5 12:59:23 2012
  GConfNonDefault:
   /apps/update-manager/check_new_release_ignore=
   /apps/update-manager/show_details=false
   /apps/update-manager/show_versions=false
  InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
  PackageArchitecture: all
  ProcEnviron:
   PATH=(custom, no user)
   LANG=en_IN
   SHELL=/bin/bash
  SourcePackage: update-manager
  VarLogDistupgradeTermlog:

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1046181/+subscriptions




More information about the foundations-bugs mailing list