[Bug 1045409] [NEW] 'reinstall grub' option missing when rescuing encrypted LVM system

Paul Larson paul.larson at canonical.com
Mon Sep 3 16:04:37 UTC 2012


Public bug reported:

Image: Quantal Beta 1 amd64 20120903.2

I installed a system with encrypted LVM, then rebooted and picked the option to boot rescue mode from the boot media.  I was able to mount root just fine, and execute a shell in it, but the only options in the 'rescue operations' menu are:
Execute a shell in /dev/beta1-server/root
Execute a shell in the installer environment
Choose a different root file system
Reboot the system

Workaround:
jibel pointed out that you can get the option to reinstall grub if you execute the shell in your root, then manually mount /boot and exit the shell.  Once you do this, the option will show up on the menu

** Affects: debian-installer (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: rls-q-incoming

** Tags added: rls-q-incoming

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to debian-installer in Ubuntu.
https://bugs.launchpad.net/bugs/1045409

Title:
  'reinstall grub' option missing when rescuing encrypted LVM system

Status in “debian-installer” package in Ubuntu:
  New

Bug description:
  Image: Quantal Beta 1 amd64 20120903.2

  I installed a system with encrypted LVM, then rebooted and picked the option to boot rescue mode from the boot media.  I was able to mount root just fine, and execute a shell in it, but the only options in the 'rescue operations' menu are:
  Execute a shell in /dev/beta1-server/root
  Execute a shell in the installer environment
  Choose a different root file system
  Reboot the system

  Workaround:
  jibel pointed out that you can get the option to reinstall grub if you execute the shell in your root, then manually mount /boot and exit the shell.  Once you do this, the option will show up on the menu

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1045409/+subscriptions




More information about the foundations-bugs mailing list