[Bug 1044668] Re: ubi-partman crashed with eit code 141

melchiaros melchiaros at aol.com
Sat Sep 1 11:37:00 UTC 2012

** Changed in: ubiquity (Ubuntu)
       Status: New => Confirmed

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to ubiquity in Ubuntu.

  ubi-partman crashed with eit code 141

Status in “ubiquity” package in Ubuntu:

Bug description:
  This is a fresh install using x86_64 nightly from 20120831 on a new Ivy Bridge laptop with 1TB HD partitioned before the install as
  (parted) print                                                            
  Model: ATA TOSHIBA MQ01ABD1 (scsi)
  Disk /dev/sda: 1000GB
  Sector size (logical/physical): 512B/4096B
  Partition Table: msdos

  Number  Start   End     Size    Type      File system  Flags
   1      32.3kB  41.1MB  41.1MB  primary   fat16        diag
   2      41.9MB  21.3GB  21.3GB  primary   ntfs         boot
   3      21.3GB  126GB   105GB   primary   ntfs
   4      126GB   1000GB  874GB   extended

  I get past the "preparing to install Ubuntu" page but after 5-10 seconds I get a "ubi-partman crashed dailog" with the error "ubi=partman failed with exit code 141"
  The "try again" button gets the same error. I am unable to get further in the installation.

  There are a number of other reports of this for older Ubuntu releases
  but as this was reproduced on the 12.10 nightly I thought it deserved
  a new bug. It is 100% reproducible

  I am a developer and happy to try patches or collect more debug info.

  My basic analysis:
   * ubi-partman failing with 141 is SIGPIPE
   * The python traceback in /var/log/syslog suggests /var/lib/partman/outfifo (FIFO to parted_server) could not be opened. outfile is a zero length file afterwards, but does seem to be a FIFO as the installer is running. I tried a time.sleep(1) before outfile was opened but it did not help.
   * The parted_server log in /var/log/partman suggests that parted_server did service requests via the FIFOs and was then asked to QUIT (but that might be a reaction to an earlier failure).

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: ubiquity 2.11.25 [modified: lib/partman/automatically_partition/question]
  ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
  Uname: Linux 3.5.0-13-generic x86_64
  ApportVersion: 2.5.1-0ubuntu4
  Architecture: amd64
  CasperVersion: 1.321
  Date: Sat Sep  1 09:05:23 2012
  ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
  InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --  nomodeset keyboard-configuration/layoutcode=gb
  InterpreterPath: /usr/bin/python3.2mu
  LiveMediaBuild: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120831)
   PATH=(custom, no user)
  SourcePackage: ubiquity
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list