[Bug 331806] Re: better handling of building for ubuntu and debian on the same host

Maarten Bezemer maarten.bezemer at gmail.com
Fri Feb 24 11:50:13 UTC 2012

No I do not want to argue with this, just stating how the bug triaging
process works.

The link I gave, states that a bug should marked Invalid if it is
unknown what fix/update/version actually solved the problem. Which is
the case here. At least, I do not know what actually solved the problem

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to pbuilder in Ubuntu.

  better handling of building for ubuntu and debian on the same host

Status in “pbuilder” package in Ubuntu:
  Fix Released

Bug description:
  Binary package hint: pbuilder

  $ dpkg -l pbuilder
  | Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
  |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
  ||/ Name                      Version                   Description
  ii  pbuilder                  0.183ubuntu1~hardy1       personal package builder for Debian packages

  $ pbuilder-dist sid create
  I: Configuring debian-archive-keyring...
  I: Configuring apt...
  I: Configuring libept0...
  I: Configuring apt-utils...
  I: Configuring aptitude...
  I: Configuring tasksel-data...
  I: Configuring tasksel...
  I: Base system installed successfully.
   -> debootstrap finished
   -> copying local configuration
    -> Installing apt-lines
  Refreshing the base.tgz
   -> upgrading packages
   -> mounting /proc filesystem
   -> mounting /dev/pts filesystem
   -> installing dummy policy-rc.d
  Get:1 http://ftp.debian.org sid Release.gpg [189B]
  Hit http://ftp.debian.org sid Release
  Ign http://ppa.launchpad.net hardy Release.gpg
  Get:2 http://ppa.launchpad.net hardy Release [27.6kB]
  Get:3 http://ppa.launchpad.net hardy/main Packages [5170B]
  Get:4 http://ftp.debian.org sid/main Packages/DiffIndex [2038B]
  Fetched 35.0kB in 32s (1090B/s)
  W: Failed to fetch http://ftp.debian.org/dists/sid/Release  Unable to find expected entry  restricted/binary-i386/Packages in Meta-index file (malformed Release file?)
  E: Some index files failed to download, they have been ignored, or old ones used instead.
   -> Aborting with an error
   -> unmounting dev/pts filesystem
   -> unmounting proc filesystem
   -> cleaning the build env
      -> removing directory /usr/src/pbuilder/build//27011 and its subdirectories

  The reason is simply that I added Ubuntu specific components in
  pbuilderrc which threw pbuilder off when trying to build for sid.

  $ grep ^COMPO /etc/pbuilderrc
  COMPONENTS="main restricted universe multiverse"

  Maybe it would be possible to change pbuilder configuration in such a
  way that it is possible to specify components on the command line or
  better yet set COMPONENTS for Debian and Ubuntu differently.

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list