[Bug 923744] Re: smbclient messaging not responding to control-D

Serge Hallyn 923744 at bugs.launchpad.net
Thu Feb 2 00:09:47 UTC 2012

Thanks for reporting this bug.  Could you verify whether

echo "hello world" > msg.txt
smbclient -U Mark -M WINDOWS-PC < msg.txt


** Changed in: samba (Ubuntu)
   Importance: Undecided => Medium

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to samba in Ubuntu.

  smbclient messaging not responding to control-D

Status in “samba” package in Ubuntu:

Bug description:
  sharing is working properly from My computer to the windows 7 computer
  generally, I transfer files from Nautilus without difficulty;

  however when I try to smbclient -M to the windows 7 computer, that has
  winsent Innocenti LAN messenger, winpopup compatible, although no
  msg.exe – replacement for net send – in system32, so as far as I know
  windows 7 home premium is thus capable of receiving messages although
  not sending them, it initially connects then seems to ignore the
  control-D 'end of message' code, it's as though smbclient itself is
  not responding. There is no sign that the control-D action is at all
  recognized in smbclient. A control-C works, naturally without sending
  the message though.

  Before I installed Innocenti the smbclient -M command was refusing to
  connect/prompt for a message at all, so it looks as though the windows
  side of it is working at least basically.

  mark at mycomputer:~$ smbclient -U Mark -M WINDOWS-PC
  Enter Mark's password: 
  Type your message, ending it with a Control-D
  Hi there!
  cli_message returned NT_STATUS_IO_TIMEOUT

  as requested in the apport-bug preliminaries, the result of smbclient
  -L localhost

  mark at mycomputer:~$ smbclient -L localhost

  Enter mark's password: 
  Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.5.8]

  	Sharename       Type      Comment
  	---------       ----      -------
  	print$          Disk      Printer Drivers
  	print           Disk      
  	IPC$            IPC       IPC Service (MyComputer server (Samba, Ubuntu))
  	MyPrinter Printer   My Printer
  Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.5.8]

  	Server               Comment
  	---------            -------
  	MYCOMPUTER         MyComputer server (Samba, Ubuntu)

  	Workgroup            Master
  	---------            -------

  the result of smbclient -U Mark -L WINDOWS-PC

  $ smbclient -U Mark -L WINDOWS-PC
  Enter Mark's password: 
  Domain=[WINDOWS-PC] OS=[Windows 7 Home Premium 7600] Server=[Windows 7 Home Premium 6.1]

  	Sharename       Type      Comment
  	---------       ----      -------
  	PrinterName    Printer   PrinterName
  	ADMIN$          Disk      Remote Admin
  	C$              Disk      Default share
  	D$              Disk      Default share
  	E$              Disk      Default share
  	IPC$            IPC       Remote IPC
  	print$          Disk      Printer Drivers
  	Users           Disk      

  	Server               Comment
  	---------            -------

  	Workgroup            Master
  	---------            -------

  Looking forward to hearing from someone :-)

  ProblemType: Bug
  DistroRelease: Ubuntu 11.04
  Package: smbclient 2:3.5.8~dfsg-1ubuntu2.3
  ProcVersionSignature: Ubuntu 2.6.38-13.54-generic
  Uname: Linux 2.6.38-13-generic i686
  NonfreeKernelModules: wl
  Architecture: i386
  Date: Mon Jan 30 14:53:21 2012
  InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
  SambaClientRegression: Yes
  SourcePackage: samba
  UpgradeStatus: Upgraded to natty on 2011-05-30 (245 days ago)

To manage notifications about this bug go to:

More information about the foundations-bugs mailing list