[Bug 381104] Re: udev postinst script fails in chroot environment

Andy Ruddock andy.ruddock at rainydayz.org
Mon Aug 6 10:00:59 UTC 2012


This bug is still present in 12.04LTS, updates fail :

Setting up udev (175-0ubuntu9.1) ...
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
start: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
invoke-rc.d: initscript udev, action "restart" failed.
dpkg: error processing udev (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 udev
E: Sub-process /usr/bin/dpkg returned an error code (1)

-- 
You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to udev in Ubuntu.
https://bugs.launchpad.net/bugs/381104

Title:
  udev postinst script fails in chroot environment

Status in “udev” package in Ubuntu:
  Triaged

Bug description:
  Binary package hint: udev

  The udev.postinst script fails to restart udev (cannot bind to socket)
  when running in a chroot environment such as that used by the ubuntu
  customisation kit (uck), because of this the script fails to complete
  configuration.

  I am attempting to build an updated live cd for jaunty 9.04 the recent udev update to version 141-1.1 causes the build to fail or if errors
  ignored the image to fail to boot. I note that other packages such as acpid do detect and work round the chroot environment.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/udev/+bug/381104/+subscriptions




More information about the foundations-bugs mailing list