[Bug 734646] Re: Kubuntu 10.10 crashes when installing

Launchpad Bug Tracker 734646 at bugs.launchpad.net
Sat Dec 3 01:05:48 UTC 2011

Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: ubiquity (Ubuntu)
       Status: New => Confirmed

You received this bug notification because you are a member of Ubuntu
Foundations Bugs, which is subscribed to ubiquity in Ubuntu.

  Kubuntu 10.10 crashes when installing

Status in “ubiquity” package in Ubuntu:

Bug description:
  Binary package hint: ubiquity

  Here's the error:

  [QUOTE]Installer Crashed
  We're sorry; the installer crashed. Please file a new bug report at
  (do not attach your details to any existing bug) and a developer will attend to the problem as soon as possible. To help the developers understand what went wrong, include the following detail in your bug report, and attach the files /var/log/syslog and /var/log/partman:
  [/QUOTE][CODE]Traceback (most recent call last):
     File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 1054, in watch_debconf_fd_helper_read
        if not callback(source, debconf_condition):
     File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 252, in process_input
       self.status = self.wait()
     File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 148, in wait
     File "/usr/lib/ubiquity/plugins/ubi-language.py", line 744, in cleanup
       self.ui.controller.translate(just_me=False, not_me=True, reget=True)
     File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 115, in translate
       self._wizard.translate_pages(lang, just_me, not_me, reget)
     File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 591, in translate_pages
       self.translate_widgets(lang=lang, widgets=widgets, reget=reget)
     File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 637, in translate_widgets
       i18n.get_translations(languages=languages, core_names=core_names, extra_prefixes=prefixes)
     File "/usr/lib/ubiquity/ubiquity/i18n.py", line 120, in get_translations
       for line in db.stdout:
   IOError: [Errno 4] Interrupted system call

  I was unable to locate the /var/log/syslog or /var/log/partman files
  as there was no way to get to a terminal from there. It also would not
  open any browser from the bug reporting link. HOWEVER, I was able to
  right-click the kde icon in the upper-left corner of the error window,
  and it had options like Advanced Desktop Settings, etc. (can't
  remember precisely) and from there, I opened a help menu, and then
  from there, I opened a bug report window in rekonq, and from there, I
  logged in to post the bug info I copied from the window into the
  forums, so I would be able to save it. Also, I was able to use the
  tools menu with the open file command, and view pretty much the entire
  file system, including the whole ntfs file system of my windows
  install. However, I could not find any files mentioned for the bug
  report inside the ubuntu folder. All it had was the grub boot files
  inside it so far. But I found it odd that I could reach anything in
  the file system that way.

  Later I attempted an install of the Kubuntu 10.10 iso via a bootable
  usb drive, and this also failed, but differently. This attempt did not
  precisely give an error, it just hung once it got to the actual
  "installing" part. I had attempted installing alongside my windows
  install. It successfully resized my ntfs partition, went through all
  the rest of the steps in the list (brief message about unable to
  unmount the cdrom, however I wasn't using a cdrom, so not sure what it
  meant. however it allowed me to continue forward with the rest of the
  steps). It got to the last step, where it does the slideshow of all
  the ubuntu features, and finally ended the slideshow saying the
  installatino would complete soon, and just stayed there. After about
  an hour, I finally tried to reboot. Couldn't halt the system with
  ctrl-alt-del, there was nothing to click on, couldnt open a terminal,
  etc. I finally pushed the power button, and the kubuntu screen said to
  remove the install media and hit enter. I did so, and it shut down. I
  booted back up, and it just booted into windows normally, with no
  reference to any kubuntu install. I checked my disk management area,
  and it had indeed resized the windows partition as requested, but it
  left the free space with no new partition. nothing had been created or
  installed in the newly vacated free space.

  I'm fairly new to any sort of linux, so I'm not sure what to do next.
  Not sure why it's doing this, and already tried getting help on the

  I'm pretty sure it should have created some sort of linux partition to
  install to, right?

  And I'm pretty sure the wubi installer shouldn't do that either.

  So it appears I can't install either inside or outside of windows at
  this point.

  I tried the various installing options, with acpi workarounds, safe
  mode video, etc. nothing worked so far.

  I read in another bug report about unknown partitions. I have a pre-
  loaded diagnostic/recovery partition on the first 10gb of my drive.
  when I ran  sudo fdisk -l >fdisklist.txt from a terminal on the live
  cd version(which works flawlessly by the way, created with the same
  downloaded iso), then it gave me this info about the drive (I ran this
  before repartitioning windows - havent run it again since):

  [code]Disk /dev/sda: 160.0 GB, 160041885696 bytes
  255 heads, 63 sectors/track, 19457 cylinders
  Units = cylinders of 16065 * 512 = 8225280 bytes
  Sector size (logical/physical): 512 bytes / 512 bytes
  I/O size (minimum/optimal): 512 bytes / 512 bytes
  Disk identifier: 0xbb6ec618

     Device Boot      Start         End      Blocks   Id  System
  /dev/sda1               1        1306    10490413+  27  Unknown
  /dev/sda2   *        1307       19458   145798144    7  HPFS/NTFS


To manage notifications about this bug go to:

More information about the foundations-bugs mailing list