[ubuntu/focal-security] libgd2 2.2.5-5.2ubuntu2.1 (Accepted)

Leonidas S. Barbosa leo.barbosa at canonical.com
Wed Sep 8 12:11:02 UTC 2021


libgd2 (2.2.5-5.2ubuntu2.1) focal-security; urgency=medium

  * SECURITY UPDATE: Heap-based buffer over-read
    - debian/patches/CVE-2017-6363-*.patch: make sure transparent
      palette index is within bounds in src/gd_gd.c and add tests in
      tests/gd/bug00383.c, tests/gd/CMakeLists.txt, tests/gd/Makemodule.am,
      tests/gd2/bug00383.c, tests/gd2/CMakeLists.txt, test/gd2/Makemodule.am.
    - CVE-2017-6363
  * SECURITY UPDATE: Out-of-bounds read
    - debian/patches/CVE-2021-38115.patch: fix a read out-of-bounds in
      reading tga header file in src/gd_tga.c.
    - CVE-2021-38115
  * SECURITY UPDATE: Double free
    - debian/patches/CVE-2021-40145.patch: fix a memory leak in
      src/gd_gd2.c.
    - CVE-2021-40145

Date: 2021-08-31 13:17:22.690077+00:00
Changed-By: leo.barbosa at canonical.com (Leonidas S. Barbosa)
https://launchpad.net/ubuntu/+source/libgd2/2.2.5-5.2ubuntu2.1
-------------- next part --------------
Sorry, changesfile not available.


More information about the Focal-changes mailing list