[ubuntu/focal-updates] cargo 0.52.0-0ubuntu1~20.04.1 (Accepted)

Ubuntu Archive Robot ubuntu-archive-robot at lists.canonical.com
Thu Aug 19 01:28:53 UTC 2021


cargo (0.52.0-0ubuntu1~20.04.1) focal; urgency=medium

  * Backport to Focal. (LP: #1932145)
  * Embed libgit2 at the revision which is embedded by the libgit2-sys
    crate, version 0.12.21+1.1.0 (which is not exactly libgit2 1.1.0,
    confusingly)
    - add debian/libgit2
    - add debian/patches/use-system-libhttp-parser.patch
    - update debian/control
    - update debian/copyright
    - update debiab/patches/series
    - update debian/README.source
    - update debian/rules

cargo (0.52.0-0ubuntu1) UNRELEASED; urgency=medium

  * New upstream version.
  * Backport patch from upstream to fix failure with new version of 'tar'
    crate.
  * Add another patch from upstream

cargo (0.51.0-0ubuntu1) hirsute; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    - Don't use the bootstrap.py script for bootstrapping as it no longer
      works.
      - remove debian/bootstrap.py
      - update debian/make_orig_multi.sh
  * New upstream release. (LP: #1915722)
  * Dropped changes:
    - Embed libgit2 1.0.0 which is not yet in Debian or Ubuntu. (Hirsute
      has a new enough libgit2)
    - d/patches/0001-relax-deprecated-diagnostic-message-check.patch,
      d/patches/u-8713.patch: included in upstream release.
  * d/patches/skip-filter_platform-non-amd64.patch: skip a test that fails on
    non amd64 platforms, see https://github.com/rust-lang/cargo/issues/9238.

cargo (0.47.0-3) unstable; urgency=medium

  * Disable close_output test for now, it is flaky. This is a test problem not
    a cargo problem and will be re-enabled in 0.49.0.

cargo (0.47.0-2) unstable; urgency=medium

  * Backport a patch to fix a test on i386.
  * Add +xgot to work around mips64el limitations.

cargo (0.47.0-1) unstable; urgency=medium

  * Upload to unstable. (Closes: #976434)

cargo (0.47.0-1~exp1ubuntu1) hirsute; urgency=medium

  * Merge from Debian experimental (LP: #1901571): Remaining changes:
    - Don't use the bootstrap.py script for bootstrapping as it no longer
      works.
      - remove debian/bootstrap.py
      - update debian/make_orig_multi.sh
    - Embed libgit2 1.0.0 which is not yet in Debian or Ubuntu.
      - add debian/libgit2
      - add debian/patches/use-system-libhttp-parser.patch
      - update debian/control
      - update debian/copyright
      - update debiab/patches/series
      - update debian/README.source
      - update debian/rules
  * d/patches/0001-relax-deprecated-diagnostic-message-check.patch:
    backport fix for tests that fail with rustc 1.47 from upstream.
  * d/patches/skip-filters_target-i386.patch: skip a test that fails on
    i386 for silly reasons.

Date: 2021-07-22 22:59:09.475068+00:00
Changed-By: Michael Hudson-Doyle <mwhudsonlp at fastmail.fm>
Signed-By: Ubuntu Archive Robot <ubuntu-archive-robot at lists.canonical.com>
https://launchpad.net/ubuntu/+source/cargo/0.52.0-0ubuntu1~20.04.1
-------------- next part --------------
Sorry, changesfile not available.


More information about the Focal-changes mailing list