[ubuntu/focal-proposed] gpgme1.0 1.13.1-6ubuntu1 (Accepted)

Steve Langasek steve.langasek at ubuntu.com
Fri Feb 14 01:56:16 UTC 2020


gpgme1.0 (1.13.1-6ubuntu1) focal; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - debian/patches/0006-PIC-and-shared.patch: Libs are -fPIC and -shared.
    - Add in libgpgme-dev a libgpgme-pthread.so pointing to libgpgme.so, this
      will fix the build failures of kf5-kdepim-apps-libs when built against
      this gpgme package.
  * Dropped changes, no longer needed:
    - Bump libgpg-error-dev build dependency to 1.28 for new gpgrt API
    - debian/patch/0007-Python-Versions.patch: won't work now that python2
      support is dropped, and doesn't appear to be needed.
  * Dropped changes, superseded in Debian:
    - Update test dependency for python->python2 move

gpgme1.0 (1.13.1-6) unstable; urgency=medium

  * brown paper bag bugfix to debian/tests :(
  * try to improve reproducibility for generated docs

gpgme1.0 (1.13.1-5) unstable; urgency=medium

  * checky2106 should not cause the build to fail
  * Standards-Version: bump to 4.5.0 (no changes needed)

gpgme1.0 (1.13.1-4) unstable; urgency=medium

  * fix up tests, cover all supported python3 versions

gpgme1.0 (1.13.1-3) unstable; urgency=medium

  * drop ${python3:Versions} from python3-gpg, i clearly don't know how to
    use it properly.

gpgme1.0 (1.13.1-2) unstable; urgency=medium

  * rebuild, pulling in python 3.8 (Closes: #944774)
   - requires patching upstream, changes to cross-building logic
  * Update standards version to 4.4.1, no changes needed.
  * add buildtime and runtime tests for platform time limits
  * remove python-gpg autopkgtest entirely (Closes: #943390, #943111)
  * update lintian-overrides for untracked C++ symbols
  * fix json tests
  * d/control: drop unused ${shlibs:Depends} from libgpgmepp-dev
  * d/control: added ${python3:Versions} to python3-gpg

gpgme1.0 (1.13.1-1) unstable; urgency=medium

  * new upstream release
  * release to unstable
  * d/{control,gpb.conf}: fix up Vcs branch name for DEP-14
  * make sure to test python decryption and verification
  * Standards-Version: bump to 4.4.0 (no changes needed)
  * Drop python2 support, only build for python3
  * go with upstream python, ignoring intermittent decrypt problems

gpgme1.0 (1.13.0-2) experimental; urgency=medium

  * refresh patches
  * fix signature verification failure when decrypting with session keys
  * ship pkgconfig file gpgme.pc
  * Definitively avoid shipping gpgme-glib.pc
  * dh_missing --fail-missing

gpgme1.0 (1.13.0-1) experimental; urgency=medium

  [ Helmut Grohne ]
  * Fix FTCBFS (Closes: #912898)

  [ Daniel Kahn Gillmor ]
  * new upstream release to experimental due to the freeze
  * move to DEP-14 debian/experimental branch
  * move to debhelper 12
  * standards-version: bump to 4.3.0 (no changes needed)
  * refresh patches (dropping those already upstream)
  * refresh lintian-overrides
  * add Build-Depends-Package field to libgpgme11.symbols
  * gbp import-orig: filter out generated VERSION file and emacs turds
  * Re-export upstream signing key without extra signatures.

Date: Thu, 13 Feb 2020 16:43:13 -0800
Changed-By: Steve Langasek <steve.langasek at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/gpgme1.0/1.13.1-6ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Thu, 13 Feb 2020 16:43:13 -0800
Source: gpgme1.0
Architecture: source
Version: 1.13.1-6ubuntu1
Distribution: focal
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Steve Langasek <steve.langasek at ubuntu.com>
Closes: 912898 943111 943390 944774
Changes:
 gpgme1.0 (1.13.1-6ubuntu1) focal; urgency=low
 .
   * Merge from Debian unstable.  Remaining changes:
     - debian/patches/0006-PIC-and-shared.patch: Libs are -fPIC and -shared.
     - Add in libgpgme-dev a libgpgme-pthread.so pointing to libgpgme.so, this
       will fix the build failures of kf5-kdepim-apps-libs when built against
       this gpgme package.
   * Dropped changes, no longer needed:
     - Bump libgpg-error-dev build dependency to 1.28 for new gpgrt API
     - debian/patch/0007-Python-Versions.patch: won't work now that python2
       support is dropped, and doesn't appear to be needed.
   * Dropped changes, superseded in Debian:
     - Update test dependency for python->python2 move
 .
 gpgme1.0 (1.13.1-6) unstable; urgency=medium
 .
   * brown paper bag bugfix to debian/tests :(
   * try to improve reproducibility for generated docs
 .
 gpgme1.0 (1.13.1-5) unstable; urgency=medium
 .
   * checky2106 should not cause the build to fail
   * Standards-Version: bump to 4.5.0 (no changes needed)
 .
 gpgme1.0 (1.13.1-4) unstable; urgency=medium
 .
   * fix up tests, cover all supported python3 versions
 .
 gpgme1.0 (1.13.1-3) unstable; urgency=medium
 .
   * drop ${python3:Versions} from python3-gpg, i clearly don't know how to
     use it properly.
 .
 gpgme1.0 (1.13.1-2) unstable; urgency=medium
 .
   * rebuild, pulling in python 3.8 (Closes: #944774)
    - requires patching upstream, changes to cross-building logic
   * Update standards version to 4.4.1, no changes needed.
   * add buildtime and runtime tests for platform time limits
   * remove python-gpg autopkgtest entirely (Closes: #943390, #943111)
   * update lintian-overrides for untracked C++ symbols
   * fix json tests
   * d/control: drop unused ${shlibs:Depends} from libgpgmepp-dev
   * d/control: added ${python3:Versions} to python3-gpg
 .
 gpgme1.0 (1.13.1-1) unstable; urgency=medium
 .
   * new upstream release
   * release to unstable
   * d/{control,gpb.conf}: fix up Vcs branch name for DEP-14
   * make sure to test python decryption and verification
   * Standards-Version: bump to 4.4.0 (no changes needed)
   * Drop python2 support, only build for python3
   * go with upstream python, ignoring intermittent decrypt problems
 .
 gpgme1.0 (1.13.0-2) experimental; urgency=medium
 .
   * refresh patches
   * fix signature verification failure when decrypting with session keys
   * ship pkgconfig file gpgme.pc
   * Definitively avoid shipping gpgme-glib.pc
   * dh_missing --fail-missing
 .
 gpgme1.0 (1.13.0-1) experimental; urgency=medium
 .
   [ Helmut Grohne ]
   * Fix FTCBFS (Closes: #912898)
 .
   [ Daniel Kahn Gillmor ]
   * new upstream release to experimental due to the freeze
   * move to DEP-14 debian/experimental branch
   * move to debhelper 12
   * standards-version: bump to 4.3.0 (no changes needed)
   * refresh patches (dropping those already upstream)
   * refresh lintian-overrides
   * add Build-Depends-Package field to libgpgme11.symbols
   * gbp import-orig: filter out generated VERSION file and emacs turds
   * Re-export upstream signing key without extra signatures.
Checksums-Sha1:
 54767330b051fcd7735df508647770eff3e568b1 3031 gpgme1.0_1.13.1-6ubuntu1.dsc
 f87f34e695e8d74ccc7c8f42864d50630afebb0e 1759616 gpgme1.0_1.13.1.orig.tar.bz2
 1aba44e2c4f898cd3b68a3290eacb8b2c09e252a 488 gpgme1.0_1.13.1.orig.tar.bz2.asc
 4e80fe00a1a99f226476632d776dead3444d0784 22096 gpgme1.0_1.13.1-6ubuntu1.debian.tar.xz
 aaef5f78587c65a3a332843865365816b0e16dd4 10990 gpgme1.0_1.13.1-6ubuntu1_source.buildinfo
Checksums-Sha256:
 f0bf1091c4422aae15e9188992fd022ba9017445176836ff15f5fc8dbdce1e2a 3031 gpgme1.0_1.13.1-6ubuntu1.dsc
 c4e30b227682374c23cddc7fdb9324a99694d907e79242a25a4deeedb393be46 1759616 gpgme1.0_1.13.1.orig.tar.bz2
 2759362727500bc9ddee86c6383b63bee0e230bd6159e63ea3cb48dc1de0f303 488 gpgme1.0_1.13.1.orig.tar.bz2.asc
 ec0c09e0954b5a07de32c9f9f8dc89203a08eb7e7b6775f22d867bb995dcb478 22096 gpgme1.0_1.13.1-6ubuntu1.debian.tar.xz
 6babab933ca026a06a4e80fcb7e71580c0cedeee6ef16a299d7ae4d0fa2988b5 10990 gpgme1.0_1.13.1-6ubuntu1_source.buildinfo
Files:
 6b2174f0dc6b7a64cb0c08b09ea65955 3031 libs optional gpgme1.0_1.13.1-6ubuntu1.dsc
 198f0a908ec3cd8f0ce9a4f3a4489645 1759616 libs optional gpgme1.0_1.13.1.orig.tar.bz2
 3f805136c39a7015116136564a21ef91 488 libs optional gpgme1.0_1.13.1.orig.tar.bz2.asc
 f8a6516abd0b58c21e09e0dbd4dbf886 22096 libs optional gpgme1.0_1.13.1-6ubuntu1.debian.tar.xz
 1488055d03ab7c866e8923aaecd306df 10990 libs optional gpgme1.0_1.13.1-6ubuntu1_source.buildinfo
Original-Maintainer: Debian GnuPG Maintainers <pkg-gnupg-maint at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----

iQJOBAEBCgA4FiEErEg/aN5yj0PyIC/KVo0w8yGyEz0FAl5F/YMaHHN0ZXZlLmxh
bmdhc2VrQHVidW50dS5jb20ACgkQVo0w8yGyEz2+BxAApkjPaPgpE7DkT6IW06Nl
+bSCb15u4V2OZ1v3wEnivUFmYAi1Wb26/wgzb2QjJTa0b6iDYWDpxSFJ9aOutGar
l/hrt5/S7q4VxnF5+T0rQO5T4bNfoIVCuJIQPiahXFOHNdKmfp2+DZRgzV8yffmg
Fuh3rZZDBDfWHlJeakVciXo62hGUv0XKuRTgE4WyPOBrCG9HkzNAJD1j86g4SDR7
P+IMd1OUQE910+GTWOxd9KI5rXKeQY3B4PJp4xNhuwPd/clT9agEQZ8TgDlHNRHy
4tnoJpuvN1wmE0psiJyUDGfIblQQpsztIFuMR20MNIGC8TmcbyI9sootwkZFeCP7
54EP15UQY9UxK9KY0+NxOZQSKDlg3qqdh6aYB1qwr1NuCUS3vqz7WfuGy6OKgHNa
nEhPhRqdBz9kRs+fHwy6EhPo3rLxac3mNaRlgsNU/QcVAFKpeP+g5cUzjkQbGyHB
i4xZAmH+s4cbtIHQ5s4Zsrb4BOM5BuCDlttZBJiYnb8GM2Drkfxn8mJcWLdfDa+K
FXF+tnjg+SboL0XDTVIR7AmFdkl0lioxIx2850cSLxvTA1a0o83rQxfdaEPJlj8I
7MZL5MFPR3+keq1692Mq3NVZYah9GZk9xiy4VK+hdDGWuKOUqdP2nw/fJoMQ7a9/
nIeGw3L3SbXtMwwkF+II9CE=
=8CAc
-----END PGP SIGNATURE-----


More information about the Focal-changes mailing list