Accepted postgresql-8.1 8.1.7-1ubuntu1 (source)

Michael Bienia geser at
Wed Feb 7 00:00:20 GMT 2007

 OK: postgresql-8.1_8.1.7-1ubuntu1.dsc
     -> Component: universe Section: misc
 OK: postgresql-8.1_8.1.7.orig.tar.gz
 OK: postgresql-8.1_8.1.7-1ubuntu1.diff.gz

Hash: RIPEMD160

Format: 1.7
Date: Wed,  7 Feb 2007 00:31:58 +0100
Source: postgresql-8.1
Binary: postgresql-8.1 postgresql-pltcl-8.1 postgresql-plperl-8.1 libpq4 postgresql-doc-8.1 postgresql-plpython-8.1 postgresql-client-8.1 postgresql-server-dev-8.1 postgresql-contrib-8.1
Architecture: source
Version: 8.1.7-1ubuntu1
Distribution: feisty
Urgency: high
Maintainer: Martin Pitt <mpitt at>
Changed-By: Michael Bienia <geser at>
 libpq4     - PostgreSQL C client library
 postgresql-8.1 - object-relational SQL database, version 8.1 server
 postgresql-client-8.1 - front-end programs for PostgreSQL 8.1
 postgresql-contrib-8.1 - additional facilities for PostgreSQL
 postgresql-doc-8.1 - documentation for the PostgreSQL database management system
 postgresql-plperl-8.1 - PL/Perl procedural language for PostgreSQL 8.1
 postgresql-plpython-8.1 - PL/Python procedural language for PostgreSQL 8.1
 postgresql-pltcl-8.1 - PL/Tcl procedural language for PostgreSQL 8.1
 postgresql-server-dev-8.1 - development files for PostgreSQL 8.1 server-side programming
 postgresql-8.1 (8.1.7-1ubuntu1) feisty; urgency=low
   * Merge from debian unstable, remaining changes:
     - debian/control: Do not build the client-side libraries, they are built
       from postgresql-8.2 now.
 postgresql-8.1 (8.1.7-1) unstable; urgency=high
   * New upstream security and bug fix release:
     - Fix security vulnerabilities that allowed connected users to
       read backend memory.
       The vulnerabilities involve suppressing the normal check that a SQL
       function returns the data type it's declared to, and changing the
       data type of a table column (CVE-2007-0555, CVE-2007-0556). These
       errors can easily be exploited to cause a backend crash, and in
       principle might be used to read database content that the user
       should not be able to access.
     - Fix rare bug wherein btree index page splits could fail due to
       choosing an infeasible split point.
     - Improve "VACUUM" performance for databases with many tables.
     - Fix autovacuum to avoid leaving non-permanent transaction IDs in
       non-connectable databases.
     - Fix for rare Assert() crash triggered by UNION.
     - Tighten security of multi-byte character processing for UTF8
       sequences over three bytes long.
     - Fix possible crashes when an already-in-use pl/pgsql function is
   * Urgency high: security relevant changes and critical bug fixes.
 0c2642677a95789e6f5f6a1d4cfd7214 1231 misc optional postgresql-8.1_8.1.7-1ubuntu1.dsc
 2fee0e657ea6772a495e15fb1cd008bf 11399892 misc optional postgresql-8.1_8.1.7.orig.tar.gz
 373924455b20adf3438341c901eb10cc 32875 misc optional postgresql-8.1_8.1.7-1ubuntu1.diff.gz

Version: GnuPG v2.0.2 (GNU/Linux)


More information about the feisty-changes mailing list