Accepted guile-1.8 1.8.1+1-1.1 (source)

Scott James Remnant scott at ubuntu.com
Fri Nov 17 02:15:54 GMT 2006


Accepted:
guile-1.8 1.8.1+1-1.1 was ACCEPTED.
	Component: universe Section: interpreters

Origin: Debian/unstable
Format: 1.7
Date: Thu,  16 Nov 2006 23:14:28 +0000
Source: guile-1.8
Binary: guile-1.8, guile-1.8-libs, guile-1.8-dev, guile-1.8-doc
Architecture: source
Version: 1.8.1+1-1.1
Distribution: feisty
Urgency: medium
Maintainer: Rob Browning <rlb at defaultvalue.org>
Changed-By: Scott James Remnant <scott at ubuntu.com>
Description: 
 guile-1.8  - The GNU extension language and Scheme interpreter
Closes: 183686 183977 184773 186877 186981 186981 187926 188322 189315 189316 191464 193868 193870 198858 198896 279280 279282 300146 316083 317600 334735 337346 338823 340149 383910 395235 395290 396922
Changes: 
 guile-1.8 (1.8.1+1-1.1) unstable; urgency=low
 .
   * NMU to fix RC bugs.
   * Build-Depend on libltdl3-dev (closes: #395235),
     libgmp3-dev (closes: #396922), and texinfo.
   * Build-Depend on locales and generate de_DE.ISO-8859-1 for use by
     the testsuite.
   * Add the above *-dev dependencies also to guile-1.8-dev (closes: #395290).
 .
 guile-1.8 (1.8.1+1-1) unstable; urgency=medium
 .
   * Incorporate new upstream stable release.
 .
   * Remove the debian/patches for items fixed upstream (all of them).
 .
   * In accordance with the recent General Resolution
     (http://www.debian.org/vote/2006/vote_001), move all non-DFSG files to
     new packages that will be included in Debian's non-free section.  The
     debian/dfsg-splitter script has been used to split the upstream
     archive.
 .
   * Version the doc package info files so that the doc package for each
     Guile stable series no longer conflicts with the doc package for other
     stable series.  This has made the virtual guile-doc package obsolete.
 .
   * Delete debian/need-empty-autofiles-diff when not needed, always start
     with an empty autofiles.diff when regenerating, and fix a few other
     things in rules.
 .
   * Work around a dh_installinfo bug.  It always inserts \Q and \E around
     the --section, which doesn't work.
 .
 guile-1.8 (1.8.0-1) unstable; urgency=low
 .
   * Incorporate new upstream release. (closes: #383910, #316083)
 .
   * Compile --with-threads=no for now to avoid a thread-related bug.  This
     should be a temporary measure.
 .
   * Move guile-config, guile-snarf, guile-tools, and guile scripts to
     guile-1.8-dev package.
 .
   * Disable SLIB support for now since Guile 1.8 doesn't support SLIB
     upstream yet.
 .
   * Rewrite the #! line of appropriate guile scripts to use the versioned
     binary name.  This should have already been the case, but the code in
     debian/rules wasn't quite right.
 .
   * When autofiles.diff is empty, it doesn't show up in the resulting
     Debian source tree (via dpkg-source -x), so fix debian/rules to
     accommodate.
 .
   * NOTE: the 1.8 package was branched from the 1.6 package before the
     1.6.7-3 release, so there are more recent 1.6 releases that are not
     shown below.
 .
 guile-1.6 (1.6.7-2) unstable; urgency=low
 .
   * Migrate from dpatch to quilt.
 .
   * Fix FTBFS with gcc-4.0.  Thanks to Daniel Schepler
     <schepler at debian.org>. (closes: #300146)
 .
   * Rebuild with current dpkg-dev to fix the cpp version in guile-snarf.
     Thanks to Daniel Schepler <schepler at debian.org>. (closes: #317600)
 .
   * Update debian/rules to support autofiles.diff, autofiles-sync, etc.
 .
   * Add (pending) upstream patch for compatibility with newer SLIB, but
     adjust the new slib.scm to load slib/init/guile.init rather than
     slib/guile.init in order to accomodate Debian's slib.
     (closes: #334735, #337346, #338823, #340149)
 .
 guile-1.6 (1.6.7-1) unstable; urgency=medium
 .
   * new upstream bugfix release. (closes: #279282)
   * updated guile-X.Y-slib package description.
   * changed build dependency to libreadline5-dev. (closes: #279280)
 .
 guile-1.6 (1.6.4-4) unstable; urgency=low
 .
   * Fix release oversight (forgot to delete beta pkg warning(s)).
 .
 guile-1.6 (1.6.4-3) unstable; urgency=low
 .
   * patch 50_gc-realloc fixes snd gc segfault. Thanks to Sam Hocevar
     <sam at zoy.org>. (closes: #198896)
   * patch 50_m68k-smob-crash fixes m68k build crash.  Thanks to Sam
     Hocevar <sam at zoy.org>. (closes: #193870)
   * patch 50_ia64-ucontext fixes ia64 ucontext related build failure.
     Thanks to Sam Hocevar <sam at zoy.org>. (closes: #193868)
   * fix guile-1.6 conflicts with libguile-dev -- didn't have epoch so
     wasn't having any effect.  guile-1.6 needs to conflict with earlier
     libguile-dev versions because they didn't use update-alternatives for
     bin/guile-X.Y*.  It can't conflict with later versions
     (i.e. guile-1.6-dev and on) because guile-X.Y-dev is supposed to
     provide/conflict with libguile-dev. (closes: #198858)
 .
 guile-1.6 (1.6.4-2) unstable; urgency=low
 .
   * continuations.h: include ucontext.h rather than sys/ucontext.h on
     ia64.  This fixes a compilation problem for things that use libguile.
     Thanks to James Treacy. (closes: bug#191464)
   * make guile-1.6 conflict with libguile-dev since libguile-dev didn't
     use update-alternatives for guile-config and guile-tools.  I believe
     this is what has been hosing guile-config in guile-1.6.
     (closes: bug#183977, bug#188322)
   * really fix debian/rules to avoid --enable-maintainer-mode during
     normal package builds.
 .
 guile-1.6 (1.6.4-1) unstable; urgency=low
 .
   * remove --list-missing from debian/rules. (closes: bug#187926)
   * try fix for libqthreads-12 per-arch build problem. Try just producing
     an empty libqthreads-12 .install file on unsupported arches.
     (closes: bug#183686)
   * fix alpha qt assembly bugs. (closes: bug#186981)
   * upstream arch related fixes.
     (closes: bug#189316, bug#189315, bug#186981, bug#186877, bug#184773)
 .
 guile-1.6 (1.6.3-4) unstable; urgency=low
 .
   * first 1.6 upload to unstable.
 .
 guile-1.6 (1.6.3-3) unstable; urgency=low
 .
   * change some /usr/bin/guile references to /usr/bin/guile-1.6 so we make
     sure to get the right version (thanks Dale).
   * unreleased test version.
 .
 guile-1.6 (1.6.3-2) unstable; urgency=low
 .
   * rearrange guile so it allows guile1.4 and guile-1.6 to coexist.
   * unreleased test version.
 .
 guile-1.6 (1.6.3-1) unstable; urgency=low
 .
   * unreleased test version.
 .
 guile-1.6 (1.6.2-1) unstable; urgency=low
 .
   * new upstream release (still not ready for Debian proper yet).
 .
 guile-1.6 (1.6.1-3) unstable; urgency=low
 .
   * handle non-qthreads architectures properly.
 .
 guile-1.6 (1.6.1-2) unstable; urgency=low
 .
   * include libguilereadline-v-12.so.* too.
   * add conflicts/replaces goops-doc to guile-1.6-doc.
 .
 guile-1.6 (1.6.1-1) unstable; urgency=low
 .
   * trial pkg.
Files: 
 d4034e0d88fc7a5c061017431a5f9535 2816100 interpreters optional guile-1.8_1.8.1+1.orig.tar.gz
 dade667d8732e9d2c77c4fa4082d1202 10872 interpreters optional guile-1.8_1.8.1+1-1.1.diff.gz
 834e819184b53ebc17b6075e3376e344 758 interpreters optional guile-1.8_1.8.1+1-1.1.dsc





More information about the feisty-changes mailing list