Accepted cli-common 0.4.6 (source)

Ubuntu Installer archive at ubuntu.com
Tue Nov 14 23:49:10 GMT 2006


Accepted:
 OK: cli-common_0.4.6.tar.gz
 OK: cli-common_0.4.6.dsc
     -> Component: main Section: interpreters

Origin: Debian/unstable
Format: 1.7
Date: Tue,  14 Nov 2006 23:25:15 +0000
Source: cli-common
Binary: cli-common, cli-common-dev
Architecture: source
Version: 0.4.6
Distribution: feisty
Urgency: low
Maintainer: Debian Mono Group <pkg-mono-group at lists.alioth.debian.org>
Changed-By: Sebastian Dr?ge <slomo at circular-chaos.org>
Description: 
 cli-common - common files between all CLI (.NET) packages
Changes: 
 cli-common (0.4.6) unstable; urgency=low
 .
   * Mirco 'meebey' Bauer
     + dh_clideps:
       - Don't parse symlinks that point to CLI assemblies.
       - Added support for MONO_PATH using -l parameter.
       - Only use the basename of DLL map targets.
         (else the shlibs lookup will fail) 
 .
 cli-common (0.4.5) unstable; urgency=low
 .
   * Mirco 'meebey' Bauer
     + debian/control:
       - Really added libxml-dom-perl dependency to cli-common-dev.
 .
 cli-common (0.4.4) unstable; urgency=low
 .
   * Dylan R. E. Moonfire
     + Created dh_clifixperms to easily correct file permissions.
   * Mirco 'meebey Bauer
     + Updated link in the CLI Policy for MS .NET term usage.
     + dh_{makeclilibs,clideps}:
       - Bumped cli-common-dev build-depends check to >= 0.4.4
     + dh_clideps:
       - Rewrote many parts.
       - Assembly ModuleRefs are now parsed.
       - Using /etc/mono/config now for resolving DLL maps.
       - Added override feature for detected dependencies, to support Suggests
         and Recommends fields. (debian/$package.clideps-override)
       - Using libxml-dom-perl now instead of hackish regex.
       - Added special handling of libc6 dependency, the package is not called
         libc6 on all architectures.
     + debian/control:
       - Removed transition dependency for cli-common on cli-common-dev.
         (7 month for a package rename transition should be more than enough)
       - Added libxml-dom-perl dependency to cli-common.
       - Updated to Standards Version 3.7.2 (no changes).
Files: 
 9f4d9f639cce571c00b55db2b1a5cf59 28997 interpreters optional cli-common_0.4.6.tar.gz
 676cb31f1576276abbcd2ae95ba8b299 618 interpreters optional cli-common_0.4.6.dsc





More information about the feisty-changes mailing list