Thanks Robert, I&#39;m going to bring my home pc in to work tomorrow and test it out. It&#39;s C2D with 2gb RAM so we&#39;ll see if there&#39;s any improvement. I&#39;ll also try enabling directx (I&#39;m assuming I have to set LDM_DIRECTX = True in /var/lib/tftpboot/ltsp/i386/lts.conf)? and installing gnash. I&#39;m curious if this is the only problem though, because Bill wrote this about 5 weeks back:<br>
<pre>I setup at<br>home a small LTSP network with a few old Dells.  The server is a<br>3.2GB/1GB RAM machine and one client is similar and my son plays<br>Flash-based games on it all the time without any problem.</pre>and Uwe is having similar issues and I doubt if he is as unfortunate in his hardware selection as I am. Thanks very much for the prompt advice though, I&#39;ll be sure to post results tomorrow. -joe<br>
<i><br></i><div class="gmail_quote">On Thu, Mar 20, 2008 at 10:19 PM, Robert Arkiletian &lt;<a href="mailto:robark@gmail.com" target="_blank">robark@gmail.com</a>&gt; wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><div>On Thu, Mar 20, 2008 at 8:32 PM, Joseph Hartman &lt;<a href="mailto:jlhartman@gmail.com" target="_blank">jlhartman@gmail.com</a>&gt; wrote:<br>


&gt; I&#39;m having the same problem as Uwe with flash being slow. In this flash game<br>
&gt; (I use it to help my kinders practice using the mouse) I can literally see<br>
&gt; the frames refreshing and it is utterly unusable. I got my gigabit uplink<br>
&gt; switch today and connected it but there was no change from the old 10/100<br>
&gt; switch I was using before. The new switch should just work out of the box<br>
&gt; right? The LED indicates it has a gigabit connection. Since this made no<br>
&gt; difference I also did a clean install of Hardy Beta hoping to see some<br>
&gt; change. Alas.<br>
&gt;<br>
&gt; Here is a link to the system monitor display after I hooked up the switch<br>
&gt; but before the Hardy install. I would say this image is typical of what I&#39;ve<br>
&gt; seen with 5 thin clients running the aforementioned flash game whether in<br>
&gt; Gutsy or Hardy with Gigabit or not (although the RAM and CPU is running a<br>
&gt; bit high since I had just opened firefox on a couple machines before I took<br>
&gt; the screenshot).<br>
&gt;<br>
&gt; The server is a Dell GX270 P4 running at 3 GHz. It seems like the whole<br>
&gt; server slows down when flash is playing, but I haven&#39;t confirmed this. With<br>
<br>
</div>You have multiple reasons for the poor performance.<br>
1) You have a weak server. It is not even dual cpu. Old netburst architecture.<br>
2) You don&#39;t have much ram. 1GB is only enough for about 7 clients.<br>
3) make sure you are running without ssh overhead for X. ( enable direct X )<br>
4) even if you get a fast server and do all the tweaking I&#39;m afraid<br>
that site is still going to be slow<br>
<br>
LTSP is not good at streaming video AND sound to thin clients. Network<br>
latency, remote X, high cpu usage for many clients just doesn&#39;t work<br>
well. It can get better than what you currently have but it will never<br>
be like running the browser locally (on the client). If you have<br>
powerful enough clients (min P3 800 + 256MB) check this out.<br>
<br>
<a href="https://help.ubuntu.com/community/UbuntuLTSP/LTSPFatClients" target="_blank">https://help.ubuntu.com/community/UbuntuLTSP/LTSPFatClients</a><br>
<div><br>
&gt; Hardy the game is even slow on the server, although this was not the case<br>
&gt; with Gutsy (BTW Hardy seems realllllllly slow to log in on the server. Like<br>
&gt; Gutsy on my laptop. Not good.) I&#39;ve tried different thin clients with no<br>
&gt; changes. I&#39;ve also tried Cat 5 and 6 cables to the clients with no change. I<br>
&gt; haven&#39;t tried Gnash in a while so I could give that a shot, but that still<br>
&gt; doesn&#39;t solve the real problem.<br>
<br>
</div>BTW Gnash just release 0.8.2.<br>
<div><br>
&gt;<br>
&gt; Is the network activity supposed to peak and valley like that? It does this<br>
&gt; even if I&#39;m doing something other than flash, like a google docs or<br>
<br>
</div>All your X display traffic is flowing through your network.<br>
<font color="#888888"><br>
<br>
--<br>
Robert Arkiletian<br>
Eric Hamber Secondary, Vancouver, Canada<br>
Fl_TeacherTool <a href="http://www3.telus.net/public/robark/Fl_TeacherTool/" target="_blank">http://www3.telus.net/public/robark/Fl_TeacherTool/</a><br>
C++ GUI tutorial <a href="http://www3.telus.net/public/robark/" target="_blank">http://www3.telus.net/public/robark/</a><br>
</font></blockquote></div><br>