Using smartboard software as a localapp

David Groos djgroos at
Sat Jan 15 22:06:46 UTC 2011

Thanks Simon and Veli-Matti.  I've moved from easier method to more involved
and am currently at my last home.  Seems the biggest problem was the 64/32
bit issues of the server/chroot... Anyway...

I'm working on your's, Veli-Matti and things were going great!  The script
stopped working with this message: any ideas:
cp: cannot stat `/usr/share/mimelnk/application/*smarttech*': No such file
or directory


On Fri, Jan 14, 2011 at 9:37 AM, Veli-Matti Lintu <
veli-matti.lintu at> wrote:

> ke, 2011-01-12 kello 22:00 -0600, David Groos kirjoitti:
> > I've been trying to install the linux smartboard software.  I'm
> > running P4 clients off an LTSP server, with a couple of apps as
> > localapps.  I can't install the smartboard server very well on the
> > server since it doesn't work on 64 bit machine.  So I tried to install
> > it as a localapp (with 32 bit arch) but got no where.  I tried to
> > install it with "sudo chroot /opt/ltsp/i386 apt-get install
> > absolute-path-of-installer-file-on-my-desktop".  It said something
> > like "package not found".  The installer file ends with .package, not
> > sure if that helps.  I saw in a previous list post by David Trask that
> > he was running this software as a localapp so I trust it can be done!
> > But how?!
> Hi,
> I managed to get the smart software installed in fatclient chroot by
> first installing it on a normal 32-bit workstation and then creating
> a .deb package from the files it installed. The .deb package can then be
> installed in the chroot with dpkg. Running it as a localapp should not
> differ from fatclient installation, although I haven't tried that. I
> documented the steps here:
> I hope it still works the same way.
> Veli-Matti
> --
> ubuntu-education mailing list
> ubuntu-education at
> Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the edubuntu-users mailing list