Samba set up error- solved

Jim Christiansen jim.c.christiansen at
Fri Feb 12 21:56:56 GMT 2010

Just a quick note about the trouble I had with getting Samba up for WinXP
client boxes being able to join a Samba domain, provide the same student
Linux logons, and have access only to their own folders using Edubuntu 9.04.

I quit trying with the 9.04 Ubuntu packages after two weeks.  I ssh'ed into
one of my two K12LTSP Centos 5.4/3 servers that runs a lab across the hall
from my computer lab.  I yum installed Samba on it, edited the stock
smb.conf file taking less than 2 minutes (I was slow), started samba and
everything worked.  My WinXP boxes could join the new room101 domain,
students can logon using their linux username and password and only have
access to their own linux folders. Nice!!   We have checked and students can
even read and save to their homes.  Woohoo!!  We are really happy with the
setup.  Students have no clue or care their files are on a different server.
 Everything works.

I must have messed something but no clue what.  The Centos 5.x version does
not require the XP reg hack that so many ubuntu readmes required.  Also
beware- if you remove or re-install samba 3.3.x (maybe other versions of
samba, too) you could have troubles in Ubuntu.  It seems many others have
happen and this is likely what lead to my troubles, although the smb.conf
file must not have been the only messed up file...  I you want my Centos/RH5
smb.conf file just email me.

Thanks everyone for the help.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the edubuntu-users mailing list