How likely to work would a Jaunty-to-Karmic server upgrade, be?

Gavin McCullagh gmccullagh at
Wed Nov 25 10:11:31 GMT 2009


On Tue, 24 Nov 2009, David Groos wrote:

> Thanks Gavin for sending your ideas!  See below for comment.
> > == Try Manual TFTP Download ==
> Didn't really get this so tried the next idea...

Fair enough, sorry.  I should have explained better.  Basically, it looked
(before) like the TFTP transfer was timing out so I was trying to see could
you run it manually.  Anyway, that appears to be working now.

> > == Watch tftp traffic on the server ==
> >        sudo tcpdump -i eth0 'udp port 69'
> After school I again was able to look at things and I tried your second
> idea.  Now, strangely enough, the client boot quite a bit further than
> before and I hadn't (purposefully) done any changes, just booted the server,
> opened the terminal and typed in above command, then tried to boot the thin
> client.  Thanks to my cell phone camera I recently got I easily recorded the
> client screen and server screen and have posted them on my
> site<>.

Your tcpdump output is showing you what is a fairly normal tftp
conversation for a computer booting with pxelinux.  The tftp server serves
all its files from /var/lib/tftpboot so those paths are within their.

The client first asks for the file pxelinux.0, then checks for a sequence
of boot config files (in /pxelinux.cfg/) based on its mac address
(00-08-02-e4-47-80 is likely the mac address of your client) and its IP
address (C0A800F3 is hex for, C0A800 is hex for 192.168.0.,
etc).  Eventually it takes the "default" file which tells it what kernel to
boot if none of the mac or ip-specific hosts are present.

The client then downloads /ltsp/i386/vmlinuz (the kernel) and
/ltsp/i386/initrd.img (the initial ramdisk) and finally
/ltsp/i386/lts.conf (the ltsp setting for individual clients).

Annoyingly you can't see the responses coming back from the server as
they're on a random other port.  You could change the command to:

       sudo tcpdump -i eth0 'host'

to see all data transferred from/to that host.  

Anyway, TFTP seems to be working now.  I'd say your problem is in the
errors mounting /dev/nbd0 and /rofs.  It's been a while since I've used a
LTSP some I'm a little rusty on the details now.


More information about the edubuntu-users mailing list