help with understanding specific directions

David Groos djgroos at
Wed Jun 17 04:34:02 BST 2009

No, I'm not asking help on following directions but understanding them ;-)

First, the good news.
Making a fresh install of Jaunty on the server with the Alternate CD install
disk went flawlessly!  I installed a few apps, then for the fun of it,
expecting issues, I tried to boot up a thin client and wow!  that worked
perfectly also!  I've still got many things to get working on the server
before I feel like I'll be really ready for next school year, nonetheless,
this has been an auspicious start.

I've got 3 questions:
I'm trying to set up LocalApps as per these instructions: and things
were going well (these instructions have been so well written that I've
followed them easily--an achievement for the instruction writers :-) )  till
I had to make a work-around for a bug w/firefox.  I then went to this page but got
stuck when I got to this instruction:

$ cat /opt/ltsp/i386/etc/init.d/
#! /bin/sh
chmod 644 /etc/resolv.conf

I figured I had to first make the script and so used gedit and did so,
making it in the i386_w_localapps directory that I'd made according to the
instructions on the first page listed above.  I also made it executable w/a
command I'd found (to 755).  My question is, what must go IN the script?
Just the last 2 lines above?  Need I type sudo first?  Should I add the
first line into the script as well but leave out the "$"?  I just checked
the permissions for /etc/resolv.conf as I was mucking around a bit and they
are currently 644.

Question 2
Also, I need to add CmapTools (freeware to schools but not open source) to
the list of localapps.  This is the main reason I'm moving to localapps.
But it seems that I can only add programs that are accessed via apt-get from
the source list.  I've already installed the application on the server and
can open it on a thin client.  The application involves a series of steps
with a java-based installer.

Any light you can shed on these questions would be greatly welcome!


PS I've installed the new (test) version of Sabayon and will begin testing
it when these issues are resolved.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the edubuntu-users mailing list