DHCP server sometimes not found

Gavin McCullagh gmccullagh at gmail.com
Wed Jan 21 21:18:29 GMT 2009


Hi,

On Wed, 21 Jan 2009, Sergio Dicandia wrote:

> No luck with DHCP ... it still doesn't give more than 4 (or 5 at best)
> addresses and then it freezes ....
> I did the tcpdump as suggested, you can find it attached ...

I think you need to include it in plain text.  That attachment seems not to
have made it through the mailing list server.

> Now I'm thinking to replace the DHCP server, but I need something on the
> server itself, or on a device (the router, maybe) since I cannot ask the
> teacher to:

> 1- start a service machine (acting as a DHCP server)
> 2 - wait until it's up&running
> 3 - start the server
> 4 - start the TCs

Since you reported the issue, so did Lars Andersson on ltsp-users.  He
found that by placing the DHCP server on a different machine the issue went
away.  I'd guess there's an issue with the standard dhcp server on ubuntu.

http://sourceforge.net/mailarchive/forum.php?thread_name=A1777BE3AA0AB44ABADA6FF66BA594ED6C358F0F61%40vkex.vindeln.se&forum_name=ltsp-discuss

If you want to get this going, I'd suggest a dhcp server on another
machine (it worked for Lars).  If you have time to try it, it would be
great if you could try to put a different dhcp server (udhcpd or dnsmasq)
on the thin client server.

> Way too tricky for people used to switch on a general button and have all the PCs running (OK, WindowsME, but)
> What about a router ? I also need to assign fixed IPs to specific MAC adddresses to be able to use iTalc ...
> 
> :-(  I'm very sad about this ....

You're not alone.  But I think we're on the right track now.  I know it's
slow, but we'll get it fixed.

Gavin




More information about the edubuntu-users mailing list