Using nubae fatclient [was Re: which release to use?]

Sameer Verma sverma at
Wed Jan 21 20:38:30 GMT 2009

On Wed, Jan 21, 2009 at 12:14 PM, Sameer Verma <sverma at> wrote:
> On Wed, Jan 21, 2009 at 11:53 AM, David Van Assche <dvanassche at> wrote:
>> From what I can see, u are very close. The problem u have is that you
>> have not created the nfs based home dirs to be able to share
>> /home/username/.
>> U should be doing this (taken from my site):
>> sudo apt-get install portmap nfs-kernel-server nfs-common
>> echo "/home,no_root_squash,async)" | sudo tee -a
>> /etc/exports /dev/null
>> sudo exportfs -a
> I've done this. I tried it a second time, but got duplicate entries. I
> fixed those manually. When I sudo exportfs -a I get
> exportfs: /etc/exports [1]: Neither 'subtree_check' or
> 'no_subtree_check' specified for export "".
>  Assuming default behaviour ('no_subtree_check').
>  NOTE: this default has changed since nfs-utils version 1.0.x
>> Also, as u correctly guessed, eth1 is normally the internal IP... so
>> switch those 2 around either in the script, or in the server....
> I switched these in the script. I'm rebuilding the client. Let's see
> what happens...

It worked!!!

The NFS part was fine. It was a mixup in the IPs of eth0 and eth1.
Mine were assigned the other way around. Local mounting of USB drive
works well too!

I'll report back with more details after palying with a few more
options in the script.

> Another thing to note is that it takes forever to re-download packages
> and build images, so I installed apt-cacher and that thing is an
> absolute boon! Now rebuilding images from scratch are a cinch!
> Sameer
>> kind Regards,
>> David
>> On Wed, Jan 21, 2009 at 8:47 PM, David Van Assche <dvanassche at> wrote:
>>> Yeah asking on the list is fine... or private to me otherwise... but
>>> this way others can benefit from the messages too. First... can u tell
>>> me your infrastructure (server, release, TC details.) I'll take a look
>>> at the errors u are getting now and post on that soon.
>>> David (nubae)
>>> On Wed, Jan 21, 2009 at 8:37 PM, Sameer Verma <sverma at> wrote:
>>>> On Thu, Jan 15, 2009 at 8:33 PM, David Van Assche <dvanassche at> wrote:
>>>>> Well, considering fatclient is not 'officially' supported, bug reports
>>>>> are a bit irrelevant, though I would welcome any help with getting the
>>>>> script working under Hardy.  To be honest I haven't looked at the
>>>>> fatclient script in a while, but I'll set up a test environment with
>>>>> hardy and go from there. I'll let you know where I get stuck, and if
>>>>> you can help, that would be much appreciated. Last time I checked, one
>>>>> couldn't even get to the ldm screen if I remember correctly.
>>>>> kind Regards,
>>>>> David Van Assche
>>>> Since the fatclient script from nubae is not officially supported, I'm
>>>> not sure where I should post questions. I'm going to post them here
>>>> and hope I can get some answers. I'm trying out the fatclient script
>>>> from
>>>> (David's site) and get a bunch of errors. I took a few photos of the
>>>> thin client when it boots up (I couldn't capture the log on the thin
>>>> client because the system becomes unusable quickly). Photos are at
>>>> My questions:
>>>> 1) When running the script as indicated on the site, I get to a point
>>>> where it asks for main user with root privileges. I am assuming this
>>>> is the user on the server who has root privileges via sudo?
>>>> 2) What went wrong? (see photos at
>>>> Any help would be great. The default thin client works fine, but the
>>>> server gets overloaded when using multimedia apps, which is what we'll
>>>> be doing this semester (begins next week). If nothing works, I'll fall
>>>> back to the default thin client.
>>>> Sameer
>>>> --
>>>> Dr. Sameer Verma, Ph.D.
>>>> Associate Professor of Information Systems
>>>> San Francisco State University
>>>> San Francisco CA 94132 USA

More information about the edubuntu-users mailing list