Testing fat clients and errors

M Rathburn stretchem at gmail.com
Tue Jan 13 18:15:21 GMT 2009

Edubuntu 8.10 amd64

I'm fiddling around with the fat client idea.  The client hardware is a
Diskless Workstation PXE1422
We already have -normal- i386 clients working great.

Followed the instructions posted here:

Tried to use the fat client plugin method posted here:

However, it wanted to use a 64 bit kernel (which matches our server).  Our
clients are 32 bit, so when booting up a client got the error about 32 bit
kernel required.  If there's a way around that using the plugin that would
be great!

So I followed the 'manual' method of building the fat client.  Did
everything but the LDAP portion since we aren't doing that here.  On the
original image build, I skipped step #7 which is about the gdm hack to get
it to startup properly.  When booting up the client, it gets to the point
where the mouse cursor and the login screen would be showed, and the screen
goes blank.  No other virtual consoles either.

Went back and did the step #7 by putting 'RCFILE_01=/etc/startgdm.sh' in the
/var/lib/tftpboot/ltsp/fati386/lts.conf file.  Now when booting up the
client it actually shows the mouse cursor and then shows the Edubuntu login
screen, but the mouse nor the keyboard work.  After a few seconds the screen
goes to a console error screen that displays the following:

There already appears to be an X server running on display :0.  Should
another display number by tried?  Answering no will cause GDM to attempt
starting the server on :0 again. (You can change consoles by pressing
Ctrl-Alt plus a function key, such as Ctrl-Alt-F7 to go to console 7.  X
servers usually run on consoles 7 and higher.)

[Yes]      No

Answering Yes seemingly does nothing, but swapping over to console 8 I see:

gdm[3782]: WARNING: GDM already running.  Aborting!
GDM already running.  Aborting!
sudo: /etc/init.d/portmap: command not found
mount: wrong fs type, bad option, bad superblock on,
missing codepage or helper program, or other error (for several filesystems
(e.g. nfs, cifs) you might need a /sbin/mount. <type> helper program)
In some cases useful info is found in syslog - try dmesg | tail or so
mkdir: cannot create directory '/var/run/drives': File exists

Answering No just locks everything up.

So obviously there's quite a lot going on here it seems.  I suppose the
first place to start would be to try to get the display to come up properly
along with keyboard and mouse control (USB nor PS/2 work).


More information about the edubuntu-users mailing list