ldm numlock (was: Ubuntu-ltsp is not a mess!)

Pierre Yann Baco pbaco at carlit.net
Thu Sep 11 18:32:25 BST 2008

Scott Balneaves a écrit :

>>    - NumLock off: Can't force NumLock ON prior to enter username and 
>> password. 8 years old kids (and their teachers...) always forget to 
>> press NumLock prior to enter their (often birtdhay date based) password, 
>> and login fails until they realize it (sometimes they don't!)
> I may be wrong here, but I'm not sure that should be part of LDM.  Personally,
> how I've always solved this is by installing the "numlockx" package, and set up
> an Xsession init script. So, create a file called /etc/X11/Xsession.d/80numlock
> with:
> numlockx on
> in it.
> However, if people feel this should be part of LTSP, we can look at adding it.
> Come to think of it, someone may have done this at the recent hackfest, so I
> can check that out, and backport to hardy if it's there.
I've already done this before bothering this list gang. Looks like 
scripts added to /opt/ltsp/i386/etc/X11/Xsession.d/ have no effect:
- Installed numlockx after chrooting to /opt/ltsp/i386.
- Tried different script names (as they're handled by run-parts), like 
"80custom_numlockx" or "80x11-common_numlockx" (see man Xsession)
- Tried different priorities (10/30/50/70/90)
- Tried different script contents (including "#!/bin/bash" or nothing 
else than "/usr/bin/numlockx").

Every change followed by an ltsp-update-image + thin client reboot. Took 
me a while...

Finally I renamed "/etc/X11/Xsession.d" to "/etc/X11/Useless", run 
ltsp-update-image, rebooted the thin client and shortly after ldm showed 
up as usual (still numlock off), although "man Xsession" says somewhere 
"Xsession next confirms that its script directory, Xsession.d, exists. 
If it does not, the script aborts."

Conclusion: Is the Xsession script and/or 
/opt/ltsp/i386/etc/X11/Xsession.d ignored during thin client boot up ?


More information about the edubuntu-users mailing list