Hardy server won't start after upgrade

Charles Austin ceaustin at gmail.com
Mon Jun 9 18:02:12 BST 2008

On Mon, Jun 9, 2008 at 12:42 PM, Krsnendu dasa <krsnendu108 at gmail.com> wrote:
> I have lilo not grub because last time I installed I used LVM and
> Hardy to defaults to LILO for that. (Not sure why.) How do I access
> recovery mode using lilo?
You will have to google for that one - I have not used LILO.  It may
not be called "recovery mode" in LILO, the proper term for it is
"single user mode".  In Fedora, for instance, you have to interrupt
the boot loader by striking a key before the delay timer expires, then
selecting the kernel to load, then typing "e"  to edit the loader for
that kernel, and type an "s" at the end of the line (for single user

> Still. I'm not sure why gnome won't start just because avahi won't
> start perhaps the errors are unrelated.
> I tried alt-ctrl-2. After entering my username and password, the intro
> text came, but the command line prompt never appeared.

Troubling.  The OS certainly is struggling with something.  Single
user, or recovery, mode is the best option.

> I tried ssh into the machine. I was prompted to accept the key, but
> after that got  "Connection closed by host."
If you suspect the Network card, this is not surprising.

If all else fails, burn a "live" CD (Knoppix) and boot your machine
from that.  You should get full access to your drives, and should be
able to edit the boot loader conf file to get the system into single
user mode (again, you will need to google for the changes to do this
in LILO).  Worst case, from a "Live CD" OS you copy off critical
directories in the event you cannot restore this installation.


More information about the edubuntu-users mailing list