[Ltsp-discuss] thin client manager

Bill Moseley moseley at hank.org
Tue Jan 29 16:34:35 GMT 2008

On Tue, Jan 29, 2008 at 11:12:26AM -0500, Charles Austin wrote:
> On Jan 29, 2008 10:49 AM, Bill Moseley <moseley at hank.org> wrote:
> > On Tue, Jan 29, 2008 at 09:43:32AM -0600, Bob Wooden wrote:
> > > I have now followed the "new" InstallX11VncOnLtspClients (listed below)
> > > and they are much better, thank you.  But, I am still receiving the
> > > following error messages:
> > >
> > > > Cannot open ``/boot/nbi.img-2.6.22-14-386'':File exists
> > > > run-parts: /etc/kernel/postrm.d/ltsp-update-kernels exited with return code 1
> >
> > This is in the chroot, right?
> No, you should exit the chroot environment before doing the
> update-image.  Wiki has been updated to reflect this.

Yes, but I think that is a different issue.

The problem I had, which is the same as Bob had, is the above errors
that show up when trying to upgrade the thin client chroot.


seems to be failing.  I'm not clear if that's because it is failing

1) it's running in the chroot when it should not be

2) if it's suppose to run in the chroot (when doing an upgrade)
and something else is causing it to fail (like /proc or /dev/pts not
being mounted).

I cut by mistake this line:

    Cannot open ``/boot/nbi.img-2.6.22-14-386'':File exists

So it makes me wonder if the ltsp-updte-kernels install script
is just not expecting for the file to already exist.

Bill Moseley
moseley at hank.org

More information about the edubuntu-users mailing list