How to map network drive ??

oedha at netscape.net oedha at netscape.net
Thu Jan 24 01:27:24 GMT 2008


What I meant was literally the command "mount", eg 

--- ok...i see...hihi....here it is
oedha at The-ELF:/media$ sudo mount -a
Password: 
oedha at The-ELF:/media$ mount
/dev/sda3 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
lrm on /lib/modules/2.6.22-14-generic/volatile type tmpfs (rw)
/dev/sda1 on /media/sda1 type fuseblk (rw,nosuid,nodev,noatime,allow_other,default_permissions,blksize=4096)
/dev/sda2 on /media/sda2 type fuseblk (rw,nosuid,nodev,noatime,allow_other,default_permissions,blksize=4096)
securityfs on /sys/kernel/security type securityfs (rw)
//192.168.1.100/shared on /media/x type cifs (rw,mand)
oedha at The-ELF:/media$ 



Okay, so it's mounting it in such a way now that root has ownership of
everything and the associated group is users.? This is good.? Can you
please try writing to the share as root, eg:

??? sudo touch /media/x/testfile

--- yes...it appears on x but .....ro mode :) :(

If testfile appears on /media/x/ then we know it's just a local permission
issue which we can alter with the fstab.? You then just need to change the
mount options so that the users group has rwx on all files too.? Add the
option
??? fmask=0775,dmask=0775

the output was :
oedha at The-ELF:/media$ sudo mount -a
WARNING: CIFS mount option 'fmask' is deprecated. Use 'file_mode' instead.
WARNING: CIFS mount option 'dmask' is deprecated. Use 'dir_mode' instead.
Password: 
oedha at The-ELF:/media$ ls -l x

-- and i changed to file_mode and dir_mode like below :
//192.168.1.100/shared /media/x cifs rw,uid=root,gid=users,file_mode=0775,dir_mode=0775 0 0

and still the same = ro mode

You're right you do need the smbfs package installed, in order that the
smbmount command is available.? All of these options are available by
looking at its manpage:

??? man smbmount 

-- i have read this man before.....and tried the options out......but still...like usual...ro mode
i wonder : is it related to the size ? since this x is up to 100Gb and my HD is only 60GB ( since linux made everything as file ), i also tried to point to the smallest folder.......it's the same result = ro mode


thanks gavin........for being patient
regards;
~E~


________________________________________________________________________
More new features than ever.  Check out the new AIM(R) Mail ! - http://webmail.aim.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/edubuntu-users/attachments/20080123/137065c1/attachment.htm 


More information about the edubuntu-users mailing list