AW: ltsp-update-image

Anton Kaser antonkaser at
Mon Jan 7 11:52:20 GMT 2008

I tried the hints below which realy would be much easier then under Feisty:

-Changed /opt/ltsp/i386/usr/share/initramfs-tools/scripts/ltsp-nbd

-sudo chroot /opt/ltsp/i386 update-initramfs -u


But the changes in ltsp-nbd seemed to be ignored:

# For DHCP
	modprobe -q af_packet

	case ${IPOPTS} in
			# Do nothing
			# Bring up device
			ipconfig -p 1068 ${DEVICE}
			ipconfig -p 1068 -c ${IPOPTS} -d ${DEVICE}
			ipconfig -p 1068 -d $IPOPTS

			# grab device entry from ip option

The same changes in the nfs-Script worked great under Feisty. Running the
dhcp-Server on alternate Port 1067/1068 worked/workes fine.
But now the client begins to boot and stops at his 2nd dhcp Request.
And I think, that’s where this script is needed.

When I leave the ltsp-nbd-script with the -p 1068 option and I start the
dhcp-server on Port 67, the clients are booting normally. So there seemes to
bo no influence whatever I change in the script.


-----Ursprüngliche Nachricht-----
Von: edubuntu-users-bounces at
[mailto:edubuntu-users-bounces at] Im Auftrag von Oliver
Gesendet: Freitag, 4. Januar 2008 13:48
An: edubuntu-users at
Betreff: Re: ltsp-update-image

On Fr, 2008-01-04 at 12:52 +0100, Anton Kaser wrote:
> I still keep trying to get changes from the ltsp-nbd into the Client-Image
> I did the following:
> change the /opt/ltsp/i386/usr/share/initramfs-tools/scripts/ltsp-nbd
right ...

> copied it to and as  /opt/ltsp/i386/initrd/nfs
> ran     mkinitramfs -o nfs
wrong ...

the changes you made to the ltsp-nbd script above will be pulled in by
the command:

sudo chroot /opt/ltsp/i386 update-initramfs -u

dont call mkinitramfs directly... 
whats the particular reason for copying it to be called nfs (which wont
be executed without further changes to the initramfs setup that defaults
to ltsp-nbd) ?

> then    ltsp-update-kernels
right ...
that copies the kernel and initramfs in the tftp dir ...

> then    ltsp-update-image
ltsp-update-image insnt needed here your initramfs gets pulled by tftp
before the image is even available ...

> But I think the ltsp-update-imgae did not use the ltsp-nbd yet!
as i said above, the initramfs isnt used from the image but only fom the
tftp dir :)

> And after the command "ltsp-update-image" I get at the end:
> Info: port 2000 is already defined with /opt/ltsp/image/i386.img in
> inetd.conf
> info: taking no action
i should probably change the messages here if it confuses you, the
"info:" should have told you something though :) it means that there is
no need to add the image to the inetd.conf since it is already there
with the exact same config the script would add. since there is no
"error:" you can rely on it having finished properly :)

> if i command out the last line in /etc/inetd.conf (2000.....) then the
> ltsp-update-image command runs to the end and says:
> Info: updating inetd config
right, and adds an identical line ;)

> any further suggestions???
> To which place and under which name should the ltsp-nbd script be copied??
just keep the name and use the update-initramfs and ltsp-update-kernels
scripts as described above, keep a backup of a working copy of the
script so you are not screwed if the clients dont boot anymore and can
roll back :)


More information about the edubuntu-users mailing list