TFTP boot problems in Gusty AMD64

Paul J. Thompson edubuntu001 at
Sat Feb 16 21:08:16 GMT 2008


I run ltsp in a bussiness environment. I have LTSP installed (Ubuntu Feisty)
in a i386 (server & client) environment. Now I am setting up a new server
that is AMD64 but the thin clients are i386.
I set up two static interfaces one 192.168.1.x for the lan side and one for the LTSP side.

I installed LTSP server sudo apt-get install ltsp-server-standalone
then I built the environment sudo ltsp-build-client --arch i386. Then I
updated the kernels sudo ltsp-update-kernels and then rebooted.

When I try to connect from the i386 client (anyone), the client gets its
address from dhcp (and is confirmed in Syslog) but TFTP just hangs. I get
TFTP........ and it just times out. Any ideas on what is wrong?
I also tried wiping  the contents of /var/lib/tftpboot/ltsp and trying the
sudo ltsp-update-kernels command again with the same results. Below is my

# Default LTSP dhcpd.conf config file.


subnet netmask {
    option domain-name "";
    option domain-name-servers;
    option broadcast-address;
    option routers;
#    next-server;
#    get-lease-hostnames true;
    option subnet-mask;
    option root-path "/opt/ltsp/i386";
    if substring( option vendor-class-identifier, 0, 9 ) = "PXEClient" {
        filename "/ltsp/i386/pxelinux.0";
    } else {
        filename "/ltsp/i386/nbi.img";

Thank you for any assistance.


Paul Thompson
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the edubuntu-users mailing list