Edubuntu Remote Desktop Issue

randy.baker at randy.baker at
Sat Aug 23 19:08:21 BST 2008

Hi Gavin:
The Windows Based VNC clients I have tried include:
Real VNC Viewer Free Edition 4.1.2
Tight VNC Viewer 1.3.9

I typically use Real VNC, and that is the VNC Viewer that I had successfully connected to the Edubuntu workstations prior to the move.  It was also the Real VNC viewer I used to confirm that I could connect to the Ubuntu workstation, but could not connect to the same system with the Edubuntu add-ons. 
The specific error message is "No matching security types, Do you wish to attempt to reconnect to"
On the network side, the IP address is statically assigned, and the VM is configured with a bridged virtual network interface.  All Edubuntu workstations are configured similarily, and can connect to each other and the Internet without any problem.
Ubuntu/Edubuntu based Remote Desktop Clients can successfully connect to the other Edubuntu workstations.
When I uncheck "allow other users to use your desktop", netstat shows that port 5900 is still available.  However, the Remote Desktop Viewer on the other Edubuntu workstations can no longer see the disabled Edubuntu workstation using the "Find" button.   I used the following command to identify what process and executable is associated with the port.
$ netstat -l -np -p | grep 5900
That returned 5653/ica.
Checking the process list, there are three processes associated with ica, and I am able to kill those three processes.  However, when I 
check netstat, port 5900 remains open with 5653/ica, and I still get the security types error.  I don't know what process to kill, and I am unclear whether this Remote Desktop is a Vino server.  I understand there are currently some problems with Vino.
I did follow the instructions in the link you provided, but that also did not work.
I have downloaded a Real VNC server for this workstation, but at this point I don't know what process to kill to remove Remote Desktop.
I have also checked to see if iptables is running.  I do not see iptables in the process list, but iptables -V returns v1.3.8,, and iptables -L returns three chains with no rules.  Just to be safe, I added the following rule:
sudo iptables -A INPUT -p tcp -m tcp --dport 5900 -j ACCEPT
I have installed vnc4server as per your e-mail, but I cannot start it up as screen 0 since the other VNC server has the screen.  I cannot kill the :0 server with vncserver.  I can start up vncserver with other screens, but I only get a simple X window.

Any help is appreciated.
Thank you.
----- Original Message ----
From: Gavin McCullagh <gmccullagh at>
To: edubuntu-users at
Sent: Saturday, August 23, 2008 11:42:47 AM
Subject: Re: Edubuntu Remote Desktop Issue


On Sat, 23 Aug 2008, randy.baker at wrote:
> Last weekend, I had to move the physical VMware server to its original
> location, and everything was shutdown gracefully, including all VM's. 
> When I powered back up, I could no longer connect the the Edubuntu
> workstations, and I cannot find any way to get them to work now. 
> According to the RealVNC website, the error I am receiving is related to
> the VNC server wanting to secure the session.  The free version of VNC
> viewer does not encrypt the session, and for this testing, encryption is
> not required.  
> Since I could not find any firewall or configuration issue preventing
> access, and having made certain all three Edubuntu workstations did not
> have the "Require Encryption" check box enabled, I created a new Edubuntu
> VM.  Here are the results.
> 1: Installed Ubuntu Workstation 9 2.6.24-19-generic
> ** Windows based VNC Clients work with this configuration.
> 2: Installed Edubuntu add-in, no reboot
> ** Windows based  VNC Clients work with this configuration.
> 3: Rebooted Edubuntu Workstation
> ** Windows based  VNC Clients DO NOT work with this configuration.
> 4: Fully patched (107 files downloaded)
> ** Windows based VNC Clients DO NOT work with this configuration.
> I have even tried the original fix of checking then unchecking the
> "Require Encryption" advanced option.

You say Windows-based VNC clients don't work.  Do Linux-based VNC clients
work?  It wouldn't be a solution, but it might be useful to help understand
the problem.  Also, have you tried any other windows-based VNC clients?

Have you tried manually starting the vino vnc server from the command line?
There's some interesting stuff here on how to control vino a little better:

You could also (as a workaround), try installing vnc4server and starting it
from the command line.  That might help get you going.


edubuntu-users mailing list
edubuntu-users at
Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the edubuntu-users mailing list