gutsy kiosk mode

Michael Redmond redmond at stat.wisc.edu
Mon Oct 29 20:11:07 GMT 2007


Reiner,

I have been trying to build a more functional, stand-alone LTSP thin 
client. So I am interested in the kiosk option. I tried building under 
7.10 and got the same error you did. I found the file in 
/etc/rc2.d/K13gdm was missing, but there is a file K30gdm. The "plugin" 
script for building a kiosk is in:

/usr/share/ltsp/plugins/ltsp-build-client/Ubuntu/030-kiosk

which is also referenced for the steps used in:

https://wiki.edubuntu.org/HowtoWriteLTSP5Plugins

I changed the line:

                 chroot $ROOT mv /etc/rc2.d/K13gdm /etc/rc2.d/S13gdm
to

                 chroot $ROOT mv /etc/rc2.d/K30gdm /etc/rc2.d/S30gdm

and rebuilt the kiosk. That seemed to work (I have firefox running on 
the ltsp client). This is probably a bug where the 030-kiosk was not 
updated with the lated versions.

Now that this is working, I am going to try substituting other 
applications for firefox so that I can get a minimal stand-alone client 
that allows ssh login and hopefully file transfer to/from local 
thin-client USB and CD/DVD drives.

Thanks
Mike

-----

Hello,

I tried to install the kiosk mode in Gutsy 7.10 with
sudo ltsp-build-client --kiosk --base /opt/ltsp-kiosk/

The installation was broken

See the last messages of the installation (Sorry some of them are in 
German) Translation = [ ]

------------------------------------------------------------------------------------------------
........
FATAL: Could not load /lib/modules/2.6.22-14-generic/modules.dep: No 
such file or directory
.....
debconf: kann [can not initalize] Frontend nicht initialisieren: Passthrough
debconf: (Failed to open fd 3: Bad file descriptor at (eval 20) line 3)
debconf: greife zurück [fall back to ??] auf das Frontend: Noninteractive
Can not write log, openpty() failed (/dev/pts not mounted?)
Wähle vormals abgewähltes Paket edubuntu-artwork-usplash.
(Lese Datenbank ... 16481 Dateien und Verzeichnisse sind derzeit 
installiert.)
[Unpack]Entpacke edubuntu-artwork-usplash (aus 
.../edubuntu-artwork-usplash_0.1.0-53_i386.deb) ...
Can not write log, openpty() failed (/dev/pts not mounted?)
[Install] Richte edubuntu-artwork-usplash ein (0.1.0-53) ...
update-initramfs: deferring update (trigger activated)

Processing triggers for initramfs-tools ...
[Use]Verwende »/usr/share/ldm/themes/edubuntu«, um »ldm-theme« 
bereitzustellen.
mv: cannot stat `/etc/rc2.d/K13gdm': No such file or directory
Fehler: Installation abgebrochen [broken].
-----------------------------------------------------------------------------

Could someone help me,

Thanks,

Reiner




More information about the edubuntu-users mailing list