Black screen when client boots - resolved (I think)

Mark Goodridge mrgoodridge at
Fri Oct 26 12:08:59 BST 2007

Good morning list,
Thanks for the help. I tried the following suggestion:

 >I believe the problem is the memory of your graphic board/ the highest 
possible color depth of your clients. I know this problem.

open /opt/ltsp/i383/etc/lts.conf
paste X_COLOR_DEPTH=16
then rebuild the image with
sudo ltsp-update-image
restart the client

... and got the usual cryptic Linux response.

Then I tried ...

 >if you use /var/lib/tftpboot/ltsp/i386/lts.conf instead, you dont need
to run the ltsp-update-image command

... and got more cryptic Linux.

Think, think, think.

Maybe I don't have ownership of the files/folders? Some fast work with 
sudo chown fixed that. Try again.

This time the client almost booted all the way (and the display was much 
  better) but just before the progress bar reached the far right end, 
the display blacked out and more cryptic Linux appeared on the screen - 
to whit "syntax error in /etc/lts.conf line = 1"

I checked and there was no lts.conf file in /etc. Now what?

Think, think, think,

Created a lts.conf file with just one line.

Moved it to /etc

And the client booted like a trooper.

So far, so good,


More information about the edubuntu-users mailing list