No Sound with Flash in Firefox

Jim Kronebusch jim at
Thu Jul 12 19:13:12 BST 2007

I have been battling this for a while now trying every darn tip I can find with google
searches, but I still can't get sound to work in flash under firefox.  System sounds
play fine on the client, and I sound works fine under movie and audio players.  I am
running a 64-bit version of Edubuntu 7.04.  I have tried running 32-bit flash under
64-bit firefox using nswrapper, flash works but no sound.  I have tried running 32-bit
firefox with 32-bit flash, flash works but no sound.  I tried installing Automatix2 for
Feisty and used it to install 32-bit Swiftfox and all 32-bit plugins for swiftfox, flash
works but no sound.  Finally I tried firing up all versions of Firefox (64-bit and
32-bit) and the 32-bit swiftfox from command line hoping the command line would show
some errors.  It did.  I get the following two errors over and over about every second,
when the error appears it makes my flash video skip a little.  First I get the can't
open shared library and immediately after that is the invalid value for card error.  The
Shared library /usr/lib/alsa-lib/ does exist, it looks like
this is installed via the libasound2-plugins package.  I have also tried installing the
libflashsupport package but this is a 32-bit only package and doesn't install on 64-bit.
 So I tried copying the file from a 32-bit system into the plugins
directory of all browsers and still flash plays, but no sound.  I have seen similar
posts regarding this particular sound module on google and have tried any suggestions I
found there as well, but still no luck.

ALSA lib ../../../src/pcm/pcm.c:2105:(snd_pcm_open_conf) Cannot open shared library

ALSA lib ../../../src/pcm/pcm_hw.c:1351:(_snd_pcm_hw_open) Invalid value for card 

Any help would be appreciated.  I have messed with so many things now I am probably
going to rebuild the machine and start from scratch (not fun).  But I would like to get
this figured out before hand so I don't just mess up another install.  Also the server
does not have a sound card installed, so the only place I can test from is on a client.

Oh, I also tried configuring firefox and plugins as a local app, but I ran into speed
issues with firefox starting up (takes 2 minutes or so to start) so I haven't even
gotten to flash troubleshooting yet.

Jim Kronebusch
Cotter Tech Department

This message has been scanned for viruses and
dangerous content by the Cotter Technology 
Department, and is believed to be clean.

More information about the edubuntu-users mailing list