Using gigabit NIC and switch with 100Mbps clients doesn't work

Scott Ledyard scott at
Tue Jan 9 12:10:16 GMT 2007

Thanks Gavin for your suggestions. It took me a while to work through your
-I had been using a cat5e cable. Swapped it out with others, but same
-/sbin/ifconfig was normal. /var/log/syslog had nothing much.
/var/log/messages had one line that indicated a successful request for NFS
services, but nothing else.
-pinging showed no problems
-Installed Ethereal (wireshark?) on server and sniffed during the thinclient
boot. DHCP fine and a bunch (100+) of NFS packets back and forth. Not
equipped to understand them, but nothing Ethereal marked as errors.
-I installed a new 6.10 Ubuntu workstation, connected @ gigabit to Edubuntu
6.10 server (it's the DHCP server) and set up a Samba share (I'm more
familiar with samba.) I could successfully tranfer a large file.
-I setup NFS share on server and when I mounted it on the workstation it
never came back to the command prompt (using the gigabit switch.) Rebooted
all and tried with 100Mbps switch. Again, it took over 60 seconds for the
client command prompt to return, but the NFS did work and I was able to
transfer the same 2MB file in a few seconds.
You may recall that I could swap switches during the thinclient boot (from
gigabit to 100) and it would continue, so I tried the same thing using this
workstation. Rebooted all and mounted NFS share while using the 100Mbps
switch. Then, switched to the gigabit switch and tried the file transfer. It
worked just as well! (FWIW, I sniffed both transfers. There were some TCP
windowing errors in both that I would consider normal, but only the gigabit
transfer had packet out-of-order TCP errors.)
So, my tenative conclusion is the client/server cannot establish a NFS share
while the gigabit switch is in place, but it can employ one when it has already
been established. Not much good when you have to boot a thinclient.
Does this information help? Any suggestions?
Thanks, Scott

On 1/5/07, Gavin McCullagh <gmccullagh at> wrote:
> The behaviour suggests your client cannot get to the nfs server while
> you're on the 1Gb port but can when you're on the 100Mb port.  That's
> quite
> strange.  It's certainly not fundamental to gigabit use -- we have a
> server
> on 1Gb and it works fine.
> It sort of looks like there's something wrong with the gigabit link but
> it's strange that you say it works in other situations.  Perhaps you're
> getting packet loss but this is only obvious in certain applications whose
> error checking is not so good (ie UDP ones such as NFS).
> A few guesses would include:
> - a faulty or below spec cable (for GBit you should need Cat5E/Cat6)
> - software errors at gigabit speeds
> - a slightly bad gigabit connection on the switch
> - some ACL rule blocking nfs traffic on the gigabit port of that switch
>    (if the switch is even capable of that)
> You could try checking:
> - output of /sbin/ifconfig for errors
> - /var/log/syslog and /var/log/messages for errors
> - try bringing up a linux machine (not as a thin client) and see can you
>    consistently mount the nfs share by hand on 100Mb and 1Gb.
> - ping the server for a while on each port and see is there any difference
>    in losses (both should presumably be zero).
> Let us know how you get on,
> Gavin
> --
> edubuntu-users mailing list
> edubuntu-users at
> Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the edubuntu-users mailing list