AW: alternate DHCP 1067/1068 in Gusty

Anton Kaser antonkaser at
Mon Dec 10 23:12:28 GMT 2007

Booting works now!!!! In Gutsy the package mknbi is not installed

apt-get install mknbi

within the chroot-Environment ( sudo chroot /opt/ltsp/i386/ ) solved the
problem with the not working mkelf-image command.

Now the clients are booting completly on port 1067.  BUT:
all the syslog-files don't work anymore: eg:

syslogd: /var/log/syslog:Permission denied

finally it comes to

* Starting Kernel log daemon ...

Ubuntu 7.10 ltsp tty1

ltsp login:

What can I do now???  Now even when I switch back to ports 67/68 the
syslogproblem remains!!!
With ltsp-build-clients I have to build a new setup and then it would work
fine again....

- So I am still using Feisty in the School Server!!!! There everything works
slow but fine!

-----Ursprungliche Nachricht-----
Von: edubuntu-users-bounces at
[mailto:edubuntu-users-bounces at]Im Auftrag von Anton
Gesendet: Dienstag, 13. November 2007 00:25
An: edubuntu-users at
Betreff: alternate DHCP 1067/1068 in Gusty


I ran the Edubuntu System on an exitsting Windows Network. I used the
alternate DHCP-Ports for this and it worked great under Feisty. For
installing i wrote 3 little Scripts. But now, under Gusty mkelf-linux
doesnot work anymore and so the 2nd DHCP request doesnot work on the
clients. The Client starts to boot and stops when the Network card waits for
the IP-Adress for the 2nd time.

- Any Idea why mkelf doesnot work anymore?? I chanched the Kernel nummber to

Here the 3 scripts in a row.

# Find the line:  #bring up device
# add  -p 1068 after ipconfig in the next 8 lines ( 3 times)
#       ipconfig -p 1068 ...

gedit /opt/ltsp/i386/usr/share/initramfs-tools/scripts/nfs

echo "copy"

cp /opt/ltsp/i386/usr/share/initramfs-tools/scripts/nfs

echo "mkinitramfs"

mkinitramfs -o /opt/ltsp/i386/initrd/nfs

# now the 2nd script will be copied into chroot environment

cp /opt/ltsp/i386/

echo "chroot /opt/ltsp/i386/"


echo "please type:   ./"

chroot /opt/ltsp/i386/

# the 2nd script:

update-initramfs -c -k 2.6.20-15-386

#echo "cd /boot"
cd /boot
#echo "mkelf-linux"

# +++++++++++ the following doesnot work anymore:
mkelf-linux --output=/boot/nbi.img-2.6.20-15-386 vmlinuz-2.6.20-15-386

echo "type exit"

# the 3rd script:

cd /var/lib/tftpboot/ltsp/i386/

cp /opt/ltsp/i386/boot/initrd.img-2.6.20-15-386 initrd.img-2.6.20-15-386

cp /opt/ltsp/i386/boot/nbi.img-2.6.20-15-386 nbi.img-2.6.20-15-386

cp /opt/ltsp/i386/boot/initrd.img initrd.img

cp /opt/ltsp/i386/boot/nbi.img nbi.img

edubuntu-users mailing list
edubuntu-users at
Modify settings or unsubscribe at:

More information about the edubuntu-users mailing list