Postfix setup

Tom Misilo tmisilo at
Tue Aug 14 15:51:02 BST 2007

I did some searching on my ISP's website and it seems they block all
requests and when I run nmap on my pc from one at school, it comes up

25/tcp filtered smtp

> > >3. You can connect by name to port 25 from your mail server, but you get
> > > "relaying denied".  This should be fixed by the "mynetworks" line above.
> > >  - you should check that.
> > Works now using mail.misilo in the alpine config, but mail still does
> > not ever get out.
> But that's for network connectivity reasons.  Postfix is now accepting mail
> on all its interfaces though.
> > >4. You can't telnet to port 25 from remote windows machine.
> > >  - can you ping the server from the windows machine, by name and ip?
> > pinging by name works and so does pinging by ip
> So DNS is okay and there's basic routing between the desktop and the mail
> server.  A firewall seems the most likely problem now.  That could be on
> either the server or the windows machine.
> > >  - what is is inet_interfaces set to in /etc/postfix/
> > inet_interfaces = all
> >
> > >  - what is the output of "netstat --listening --tcp"
> > tcp        0      0 *:smtp                  *:*                     LISTEN
> > tcp        0      0 localhost:2207          *:*                     LISTEN
> Postfix is listening on all interfaces but packets are getting dropped or
> blocked between your windows machine and your mail server on tcp port 25.
> On the server run:
>         sudo tcpdump -i ethX port 25
> changing ethX to be the interface you expect packets to arrive on (eth0
> most likely?).  With the above running, redo the telnet on the windows
> machine and you should see packets appearing on the tcpdump.  If the
> packets arrive to the server, there is some issue (most obviously a
> firewall) on the server.  If packets don't arrive, they're getting stopped
> before they get to the server -- probably by a firewall on the client.

Okay I ran this and tried connecting to it via telnet from the windows
pc, but no packets appear. tried it about ten times hoping something
would come up :)

I also opened port 25 on the windows firewall and no luck, nor with
turning it completely off.

Also this is the output of iptables --list

root at linus:~# iptables --list
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination


More information about the edubuntu-users mailing list