public folder file permissions

Ian Moore ian15moore at
Thu Apr 19 17:31:52 BST 2007

 Great it works now.

 Clocking off for the weekend so will have some thorough testing of the system done next week.

 Once again thanks for the invaluable help.


 Message Received: Apr 19 2007, 03:26 PM
 From: "Gavin McCullagh" <gmccullagh at>
 To: edubuntu-users at
 Subject: Re: public folder file permissions
 On Thu, 19 Apr 2007, Ian Moore wrote:
 >  Okay I've added umask 002 to all of the below files.
 >  /etc/profile
 >  /etc/gdm/xsession
 >  /etc/X11/XSession
 >  /etc/login.defs
 I suspect you only need 1st and 2nd, but anyway.
 >  Files created via 'touch' in the terminal are fine (read/writeable by
 >  all the users) and also the umask returns 002
 >  But creating a text file via the GUI results in a file with permissions 
 >	rw -- --
 Bummer.  Out of curiosity, if you create a file with openoffice what
 happens?  It may just be nautilus.
 >  Doing a ls -la returns 
 >	drwxrwsrwx 22 foe     foe      4096 2007-04-19 14:48 public
 you seem to have given global permissions on public.  That shouldn't be
 necessary.  However, it does seem fine otherwise.
 > Is this just a bug in the gnome GUI? I think I've got the groups right.
 Looks like it:
 I've just tried this out on the beta version of Feisty and it seems to be
 fixed now.  I created a text file by right-clicking on the desktop and it
 was created with -rwxrwx---.  I guess you might have to wait until feisty
 (which is due out today) to have n.
 edubuntu-users mailing list
 edubuntu-users at
 Modify settings or unsubscribe at:

More information about the edubuntu-users mailing list