Edubuntu does not work with DHCP Konfiguration on port 1067

mailing-joergd at mailing-joergd at
Mon Aug 7 15:38:09 BST 2006

Hello everybody,

I am trying to set up a LTS for our school (20+ clients). I decided for edubuntu, as I am used to work with ubuntu.

The classroom is already running a terminal server solution, which uses pxe. But it is a commercial solution, not very flexible. My task is to implement a thinclient solution WITHOUT touching the existing system. A testbed server is available, the clients will be booted via diskette. AFAIK, the best possibility to realize this is shifting edubuntu to work on dhcp port 1067.

I've done these steps:
- Changed the dhcp server port in /etc/init.d/dhcp3-server
- Configured a diskette via to work on port 1067/1068 (ALTERNATE_DHCP_PORTS_1067_1068)

The client's first dhcp request is correctly answered, and he gets his linux image via tftp. So far so good...

Unfortunately, there's trouble when the client sends his second dhcp request. He gets the wrong ip configuration, as he asks the wrong (the existing) dhcp server. Consequentially, the client is unable to mount the nfs.

So I searched for workarounds:
Adding the option-129 to the dhcp configuration (as read on

As far as I understood, the option-129 setting only works with etherboot images. Edubuntu does not deliver etherboot images by default. Therefore, I created a etherboot image as described at .

Afterwards I added the following lines to my /etc/ltsp/dhcpd.conf:
	option option-128 code 128 = string;
	option option-129 code 129 = text;
	filename "/ltsp/vmlinuz.mkelf-etherboot"; #The new image created with mkelf-linux
	option option-128 E4:45:74:68:00:00;
	option option-129 "DPORT=1067";
Result: No improvements

According to the mknbi manual page, the options have to be specified in this format:
	option etherboot-signature code 128 = string;
	option kernel-parameters code 129 = text;
	option etherboot-signature E4:45:74:68:00:00;
	option kernel-parameters "DPORT=1067";
Result: No improvements (Client again gets the wrong IP, I suppose it is doing exactly the same as option-128/option-129?)

Next, I tried some more brutal things...
Configuring the kernel as described in the LTSP documentation. This has failed because of several reasons (be happy, I won't tease you with the problems in this mail :-)

However, I came along the ltsp_initrd_kit. Interesting, because here we can see how the DPORT argument is handled in the linuxrc script (i.e. it is handled). 

I tried to use the containing etherboot image vmlinuz-2.4.24-ltsp-4 in my dhcp config file - and it seems to recognize the DPORT setting! But using this image causes a lot of other problems (nfs mount fails afterwards). If someone tells me how to get the client's output to a file, I can paste it.

Folks, I really need your help. Is there any way to build a customized cient's image (based on the edubuntu image)? Why is the DPORT parameter not recognized?

I think it should be possible to set up a edubuntu environment without editing a existing system which is based on PXE or whatever, shouldn't it?

Thank you
Jörg Deutschmann

"Feel free" – 10 GB Mailbox, 100 FreeSMS/Monat ...
Jetzt GMX TopMail testen:

More information about the edubuntu-users mailing list