Sugar in Jaunty

Morgan Collett morgan.collett at gmail.com
Tue Jan 13 13:59:01 UTC 2009


On Tue, Jan 13, 2009 at 12:11, David Van Assche <dvanassche at gmail.com> wrote:
> I agree, and in fact, there are still a lot of things in sugar itself
> that haven't been ubuntified... I think we should aim to get it all
> working for Jaunty and then package it in ubuntu educational for
> Jaunty+1

I agree too. We need to get it working well first...

> For starters, we need to get abiword and its dependencies working
> within sugar... A good 10% of sugar apps depend on this (read, write,
> jigsaw, puzzle slider, etc)
>
> kind Regards,
> David Van Assche
>
> On Tue, Jan 13, 2009 at 8:23 AM, Jordan Mantha <laserjock at ubuntu.com> wrote:
>> I was looking at Sugar this evening (thanks for the prod David) and
>> what it would take to get it into Main. Unfortunately I can't see how
>> we can possibly get it done for Jaunty. The current list of
>> dependencies we'd also have to get into Main (just for sugar and
>> sugar-activites) is:
>>
>> empy
>> farsight
>> gst-plugins-farsight
>> hippo-canvas
>> json-py
>> libjingle0.3
>> libmatchbox
>> libxsettings-client
>> matchbox-window-manager
>> simplejson
>> sofia-sip
>> sugar-base
>> sugar-toolkit
>> telepathy-gabble
>> telepathy-glib
>> telepathy-python
>> telepathy-salut
>> telepathy-stream-engine

telepathy-stream-engine is an unnecessary dependency and was from
quite a while back when we had a video-chat activity under active
development. AFAIK that should drop libjingle, farsight,
gst-plugins-farsight and sofia-sip.

I don't know if all the sugar-* package dependencies are correct -
we'd need the following as well which should be somewhere in the deps
tree:
* sugar-artwork
* python-olpc-datastore (sugar-datastore)
* sugar-presence-service
* python-hulahop (sugar-hulahop)

>> I think that's just too much for us to do with the time we have. I
>> think our time would be better spent getting Sugar in better shape
>> (David wants to make sure collaboration works well) and putting a nice
>> plug for it in our release announcement/notes.

One more issue we need to improve before we can support Sugar well -
the hulahop dependency on xulrunner which breaks with every firefox
security update (/usr/lib/xulrunner-1.9.0.4 ->
/usr/lib/xulrunner-1.9.0.5...). The Ubuntu Mozilla Team suggested
using something called standalone glue to link to xulrunner, but
that's not possible with pyxpcom. Debian's xulrunner doesn't change
version numbers in paths with every update...

Regards
Morgan




More information about the edubuntu-devel mailing list