[ubuntu/disco-proposed] qtwebkit-opensource-src 5.212.0~alpha2-21ubuntu1 (Accepted)

Gianfranco Costamagna locutusofborg at debian.org
Thu Mar 28 18:43:17 UTC 2019


qtwebkit-opensource-src (5.212.0~alpha2-21ubuntu1) disco; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - Disable all-in-one build on ppc64el, otherwise GCC gets an ICE.
    - Add a patch to fix FTBFS with all-in-one mode disabled.
    - Build with -g1 instead of -g on ppc64el, to make the linker happy.

qtwebkit-opensource-src (5.212.0~alpha2-21) unstable; urgency=medium

  * Add fastcall attribute to JSImageConstructor::construct method.
    This fixes crash on i386 (closes: #909366, #924402). Thanks Bernhard
    Übelacker for the patch!
  * Remove -fpermissive from build flags. It was wrong and not needed
    with the applied patch.

qtwebkit-opensource-src (5.212.0~alpha2-20) unstable; urgency=medium

  * Backport two upstream commits to fix page width in plain text messages
    in Trojitá (fix_trojita_plaintext.diff; closes: #919522).
  * Update to debhelper compat level 12.
  * Use the new cmake+ninja buildsystem.
  * Drop the documentation packages. They cannot be built properly with
    qdoc 5.11. See https://github.com/annulen/webkit/issues/793.
  * Update symbols files from buildds’ logs.
  * Fix libpng warning by running pngcrush during build.

Date: Wed, 27 Mar 2019 18:01:38 +0100
Changed-By: Gianfranco Costamagna <locutusofborg at debian.org>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/qtwebkit-opensource-src/5.212.0~alpha2-21ubuntu1
-------------- next part --------------
Format: 1.8
Date: Wed, 27 Mar 2019 18:01:38 +0100
Source: qtwebkit-opensource-src
Binary: libqt5webkit5-dev libqt5webkit5 qml-module-qtwebkit
Architecture: source
Version: 5.212.0~alpha2-21ubuntu1
Distribution: disco
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Gianfranco Costamagna <locutusofborg at debian.org>
Description:
 libqt5webkit5 - Web content engine library for Qt
 libqt5webkit5-dev - Web content engine library for Qt - development files
 qml-module-qtwebkit - Qt WebKit QML module
Closes: 909366 919522 924402
Changes:
 qtwebkit-opensource-src (5.212.0~alpha2-21ubuntu1) disco; urgency=low
 .
   * Merge from Debian unstable.  Remaining changes:
     - Disable all-in-one build on ppc64el, otherwise GCC gets an ICE.
     - Add a patch to fix FTBFS with all-in-one mode disabled.
     - Build with -g1 instead of -g on ppc64el, to make the linker happy.
 .
 qtwebkit-opensource-src (5.212.0~alpha2-21) unstable; urgency=medium
 .
   * Add fastcall attribute to JSImageConstructor::construct method.
     This fixes crash on i386 (closes: #909366, #924402). Thanks Bernhard
     Übelacker for the patch!
   * Remove -fpermissive from build flags. It was wrong and not needed
     with the applied patch.
 .
 qtwebkit-opensource-src (5.212.0~alpha2-20) unstable; urgency=medium
 .
   * Backport two upstream commits to fix page width in plain text messages
     in Trojitá (fix_trojita_plaintext.diff; closes: #919522).
   * Update to debhelper compat level 12.
   * Use the new cmake+ninja buildsystem.
   * Drop the documentation packages. They cannot be built properly with
     qdoc 5.11. See https://github.com/annulen/webkit/issues/793.
   * Update symbols files from buildds’ logs.
   * Fix libpng warning by running pngcrush during build.
Checksums-Sha1:
 6cbc32bcd88b428eede4c0ab05cb97ff93c30071 3334 qtwebkit-opensource-src_5.212.0~alpha2-21ubuntu1.dsc
 3d3b92167ed9a616ffb993778d5d62601cf04d04 69492 qtwebkit-opensource-src_5.212.0~alpha2-21ubuntu1.debian.tar.xz
 77f18ae4399c97505d9232025b7fced1a3765fc2 19158 qtwebkit-opensource-src_5.212.0~alpha2-21ubuntu1_source.buildinfo
Checksums-Sha256:
 188b9c0de37f7245ac332f7a8486f849488fdacb0e3b331ac330c7ef3af374a6 3334 qtwebkit-opensource-src_5.212.0~alpha2-21ubuntu1.dsc
 162f9f3f55aaa011b76f54124c76a862c3cbba86c5fe138eee0e7bf7026da89e 69492 qtwebkit-opensource-src_5.212.0~alpha2-21ubuntu1.debian.tar.xz
 a35e97f7f15e76ef39525ffa3b445c1e79514ee6f2c6337e60960916f7e2a1f4 19158 qtwebkit-opensource-src_5.212.0~alpha2-21ubuntu1_source.buildinfo
Files:
 c1562262f28be5ea62913601829e6229 3334 libs optional qtwebkit-opensource-src_5.212.0~alpha2-21ubuntu1.dsc
 2e4cd7485978305a0157f42654c3c879 69492 libs optional qtwebkit-opensource-src_5.212.0~alpha2-21ubuntu1.debian.tar.xz
 e4b451b61d01386b3a947943d6a078c7 19158 libs optional qtwebkit-opensource-src_5.212.0~alpha2-21ubuntu1_source.buildinfo
Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde at lists.debian.org>


More information about the Disco-changes mailing list