[ubuntu/disco-proposed] libmoosex-xsaccessor-perl 0.009-1 (Accepted)

Gianfranco Costamagna costamagnagianfranco at yahoo.it
Mon Feb 25 16:58:34 UTC 2019


libmoosex-xsaccessor-perl (0.009-1) unstable; urgency=medium

  [ upstream ]
  * New release.

  [ Salvatore Bonaccorso ]
  * Update Vcs-* headers for switch to salsa.debian.org.

  [ gregor herrmann ]
  * Update URLs from {search,www}.cpan.org to MetaCPAN.
  * Update GitHub URLs to use HTTPS.

  [ Jonas Smedegaard ]
  * Simplify rules.
    Stop build-depend on devscripts cdbs.
  * Lower debhelper compatibility level to 9:
    Aligning with oldstable improves backportability.
  * Relax to (build-)depend unversioned
    on debhelper libclass-xsaccessor-perl libmoose-perl,
    and stop depend explicitly
    on (recent perl or) libtest-simple-perl:
    Needed versions satisfied even in oldstable.
  * Mark build-dependencies needed only for testsuite as such.
  * Declare compliance with Debian Policy 4.3.0.
  * Set Rules-Requires-Root: no.
  * Stop build-depend on dh-buildinfo.
  * Wrap and sort control file.
  * Update copyright info:
    + Use License-Grant and License-Reference fields.
      Thanks to Ben Finney.
    + Use https protocol in Format and Upstream-Contact URLs.
    + Extend coverage of packaging.
    + Extend coverage for main upstream author.
  * Add lintian overrides regarding License-Reference.
  * Update git-buildpackage config: Filter any .git* file.
  * Update watch file:
    + Bump to file format 4.
    + Track only MetaCPAN URL.
    + Rewrite usage comment.
    + Use substitution strings.

Date: 2019-02-22 22:34:57.946091+00:00
Signed-By: Gianfranco Costamagna <costamagnagianfranco at yahoo.it>
https://launchpad.net/ubuntu/+source/libmoosex-xsaccessor-perl/0.009-1
-------------- next part --------------
Sorry, changesfile not available.


More information about the Disco-changes mailing list