[ubuntu/disco-proposed] ruby2.5 2.5.1-6ubuntu1 (Accepted)

Matthias Klose doko at ubuntu.com
Sun Nov 4 08:57:32 UTC 2018


ruby2.5 (2.5.1-6ubuntu1) disco; urgency=medium

  * Merge with Debian; remaining changes:
    - Allow either Fetcher or OpenSSL exceptions when using invalid cert in
      rubygems testcase.
    - Cherrypick upstream commit to fix session resumption with TLS 1.3.
    - Cherrypick upstream commit to bump the test key size for OpenSSL 1.1.1.

ruby2.5 (2.5.1-6) unstable; urgency=medium

  * Fix build with openssl 1.1.1 (Closes: #907790)
    - Apply Ruby upstream patch to update openssl extension to v2.1.1. This
      includes some, but not all, changes needed to make the tests pass
      against openssl 1.1.1
    - Apply ruby-openssl upstream patches to fix tests against openssl 1.1.1
    - Exclude tests that still fail with openssl 1.1.1
    - debian/rules: set OPENSSL_CONF to /dev/null when running tests to use
      the default openssl settings. Unfortunately there are too many tests for
      several parts of the Ruby standard library that use openssl and that take
      very long to complete under the Debian settings, and I don't have the
      cycles to go fix each one.
    - debian/tests/run-all: also run autopkgtest against the default openssl
      settings and not the Debian-specific ones.
  * debian/tests/run-all: fix reference to excludes dir

Date: Sun, 04 Nov 2018 09:39:53 +0100
Changed-By: Matthias Klose <doko at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/ruby2.5/2.5.1-6ubuntu1
-------------- next part --------------
Format: 1.8
Date: Sun, 04 Nov 2018 09:39:53 +0100
Source: ruby2.5
Binary: ruby2.5 libruby2.5 ruby2.5-dev ruby2.5-doc
Architecture: source
Version: 2.5.1-6ubuntu1
Distribution: disco
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Matthias Klose <doko at ubuntu.com>
Description:
 libruby2.5 - Libraries necessary to run Ruby 2.5
 ruby2.5    - Interpreter of object-oriented scripting language Ruby
 ruby2.5-dev - Header files for compiling extension modules for the Ruby 2.5
 ruby2.5-doc - Documentation for Ruby 2.5
Closes: 907790
Changes:
 ruby2.5 (2.5.1-6ubuntu1) disco; urgency=medium
 .
   * Merge with Debian; remaining changes:
     - Allow either Fetcher or OpenSSL exceptions when using invalid cert in
       rubygems testcase.
     - Cherrypick upstream commit to fix session resumption with TLS 1.3.
     - Cherrypick upstream commit to bump the test key size for OpenSSL 1.1.1.
 .
 ruby2.5 (2.5.1-6) unstable; urgency=medium
 .
   * Fix build with openssl 1.1.1 (Closes: #907790)
     - Apply Ruby upstream patch to update openssl extension to v2.1.1. This
       includes some, but not all, changes needed to make the tests pass
       against openssl 1.1.1
     - Apply ruby-openssl upstream patches to fix tests against openssl 1.1.1
     - Exclude tests that still fail with openssl 1.1.1
     - debian/rules: set OPENSSL_CONF to /dev/null when running tests to use
       the default openssl settings. Unfortunately there are too many tests for
       several parts of the Ruby standard library that use openssl and that take
       very long to complete under the Debian settings, and I don't have the
       cycles to go fix each one.
     - debian/tests/run-all: also run autopkgtest against the default openssl
       settings and not the Debian-specific ones.
   * debian/tests/run-all: fix reference to excludes dir
Checksums-Sha1:
 8c913b3dea24dc29df17ee83e5acf74a2a366908 2545 ruby2.5_2.5.1-6ubuntu1.dsc
 108206ba35aaa002aeb23837d0e8dbc68c237f75 126920 ruby2.5_2.5.1-6ubuntu1.debian.tar.xz
 fdfdf6c2efb0d957c929fc0a83e42ed2775026e4 6310 ruby2.5_2.5.1-6ubuntu1_source.buildinfo
Checksums-Sha256:
 06db3550b28d630d4e10f064ba94a9ace0f4818ce2f93b970795ac2700a41d3f 2545 ruby2.5_2.5.1-6ubuntu1.dsc
 5beea91a59c72609b753c774982b0078e305e5a2a8370cf50eae33871535292f 126920 ruby2.5_2.5.1-6ubuntu1.debian.tar.xz
 69115da95d2b4a794be56c08511e58294ee40126a89de2d560c41d9a4c2c7689 6310 ruby2.5_2.5.1-6ubuntu1_source.buildinfo
Files:
 12ffaab9299ae0e972f7ed085b2c2ab1 2545 ruby optional ruby2.5_2.5.1-6ubuntu1.dsc
 e5a3bd34a9b9eaca00015dd332047a8a 126920 ruby optional ruby2.5_2.5.1-6ubuntu1.debian.tar.xz
 d507fb2a7356e24dd716f27cdf2799bb 6310 ruby optional ruby2.5_2.5.1-6ubuntu1_source.buildinfo
Original-Maintainer: Debian Ruby Team <pkg-ruby-extras-maintainers at lists.alioth.debian.org>


More information about the Disco-changes mailing list