[Bug 69541] Re: gedit cannot open any text file

Pieter Nagel pieter at nagel.co.za
Wed Jan 10 18:01:42 UTC 2007


I suggest that other people who still have this bug first make backups
of all icon-theme.cache files in subdirectories of /usr/share/icons
before trying the workaround I posted, so the maintainers have access to
the "corrupt" versions of those files for debugging.

Re: Sebastiens question, I was definitely using the Human theme & Human
theme with Gartoon icons, and I tried lots of other themes which I can't
remember, but gave up after not finding any theme that made gedit work.

Further evidence pointing to a more general gtk-level problem with
icons:

Since I did the gtk-update-icon-cache workaround and restarted X, the
little orange "asterisk" icon that tells you if there are updates
available suddenly re-appeared on my panel. I realise I hadn't seen it
since dapper.

I could be mistaken, but I think the Gnome Help icon also reappeared.

Also, I reported in this thread that bug-buddy itself was missing icons.
I ran "bug-buddy  --appname foo --pid 1" on the console and this time I
got only one warning about a missing icon ("Couldn't load icon for Open
Folder"). Unfortunately, I did not voluntarily invoke bug-buddy this way
before, so this is not an exact comparison to what I reported before.

-- 
gedit cannot open any text file
https://launchpad.net/bugs/69541




More information about the desktop-bugs mailing list