[Bug 64623] Gnome-terminal fails to start when Xinerama enabled with nvidia-glx

Matthew Haughton snafu109 at gmail.com
Mon Oct 9 09:21:06 UTC 2006

Public bug reported:

When Xinerama is enabled when using the proprietary nvidia drivers,
gnome-terminal fails to start. When run from an alternative terminal
(konsole), the error is:

The program 'gnome-terminal' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 105 error_code 2 request_code 78 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I've tried several combinations of xorg.conf with both open-source nv
and proprietary nvidia drivers. Each combination worked with gnome-
terminal, except when xinerama was enabled.

When I tried commenting xinerama out of my otherwise working xinerama
enabled xorg.conf, gnome-terminal worked. Uncommenting xinerama meant
that it would not start.

There's more info in bug <a

** Affects: gnome-terminal (Ubuntu)
     Importance: Undecided
         Status: Unconfirmed

Gnome-terminal fails to start when Xinerama enabled with nvidia-glx

More information about the desktop-bugs mailing list